Transfer Learning with MobileNet timeout error: Temporary failure in name resolution

I’m running the assignment in the web-based labs environment as standard. Trying to run the cell fetching mobilenet weights is failing with the following exeception:

URL fetch failure on https://storage.googleapis.com/tensorflow/keras-applications/mobilenet_v2/mobilenet_v2_weights_tf_dim_ordering_tf_kernels_1.0_160.h5: None – [Errno -3] Temporary failure in name resolution

I haven’t edited this cell at all and it ran fine a couple of days ago when I ran this part of the notebook.

Similar behaviour further down in the assignment notebook in Exercise 2 when trying to download weight in cell testing the alpaca_model function:

Exception: URL fetch failure on https://storage.googleapis.com/tensorflow/keras-applications/mobilenet_v2/mobilenet_v2_weights_tf_dim_ordering_tf_kernels_1.0_160_no_top.h5: None – [Errno -3] Temporary failure in name resolution

I’ve tried restarting the kernel and rerunning it from the start several times, but the behaviour is unchanged. Didn’t have any issues a few days ago when I first started the programming exercise.

Other students have reported this error on different notebooks over the last week or so. Here’s another thread about this in Course 5 a couple of days ago. It looks like some kind of intermittent problem in the Coursera AWS backend. The only thing I can suggest is to wait and try again. In the other instances we’ve seen, it usually clears up within 4 to 6 hours. You can also try reporting this to the Coursera Help Center, but as you saw on that other thread students who reported that were told by Coursera to contact their course Forums. Even though it does legitimately appear to be a Coursera problem at least IMHO.

Of course it could also be a problem at your ISP or with the DNS servers on your network, but in that case you’d expect to see other problems with your web access in general. If DNS is not working, basically nothing works.