"Trying Generative AI code yourself (optional) not launching

When I try to launch the App from Coursera’s week 2 link, a browser page opens with just this text:

“{“code”:500,“result”:false,“message”:“Request method ‘GET’ not supported”,“data”:null}”

Hi Luis, and welcome to the community! This might be just a temporary outage. The lab is working fine for me. Please clear your browser cache (if possible), re-login to Coursera, then retry launching the lab again. Hope it works!

Thanks Chris - I have cleared the cache, did a re-login to Coursera and I am still getting the same message. I have used 2 different browsers: Safari and Chrome. Same result.

Hi Luis. Are you accessing this from your workplace or in a shared wifi environment? It’s possible that your network inadvertently blocks traffic from Vocareum/AWS. If you have a network administrator, maybe you can also bring this up with them to see if that’s indeed the case.

Hi Chris - This is a personal Mac computer. From home. Using my own personal wifi.

Hmm… That’s strange. One more thing to try before we escalate. Can you go to Incognito mode and try launching it from there? If it still doesn’t work, please open Chrome’s built-in Developer Tools and see the Console output. Please post a screenshot of the entire browser including the error message, address bar, and the Console output. Thanks!

Hi Chris - I found a workaround which is using the browser version of Coursera. The use case that’s (still) not working is when I launch it from the Coursera app on my Mac. It tries to launch it in my browser (Safari or Chrome) but gives back an API error. You might want to share that bug with the dev team. Thanks for all your help!

1 Like

Great! Thanks for sharing the solution!