Unable to run notebook

I’m trying to run the notebook for Lesson 6, and getting this error. Is this a known issue?

Hi @Ichiro

Welcome to the community.

this is not necessarily a error. It is some kind of warning.

Try to run all the cell codes just to make sure.

Thank you. It fails at the cell 46:

1 Like

Just to make sure. Do you run the cells one by one? I asks because one cell depends from another cell results

One more question: are you running locally or from the course platform?


I’m running the cells one by one from the course platform.



1 Like

Hi @Ichiro! What’s the value of the variable “query_embedding”? If it’s “message”, then you may have the same problem as I’m having over here: ValueError: could not convert string to float: 'message' - Q&A - #22 by indiaj27

1 Like

@indiaj27 It was ‘message’ as you guessed. Thank you! :smiley:

@Ichiro Don’t thank me yet, I haven’t been able to resolve it :sweat_smile: Maybe though if more people are having the issue then it’s not just something specific to my computer but something wrong with the platform. Not sure if @elirod could recommend a way for us to escalate this to someone?


I was just looking at the thread and realized it’s an on-going issue :sweat_smile:

One thing that “worked” (although it’s not ideal) was to create a new account. For some reason I can run the notebooks from that new account but not this one I’m typing from now

1 Like

Hi @Ichiro and @indiaj27

kindly share your both environment please:

  1. Operation System and version

  2. Browser and version

  3. Browser plugins if installed

  4. Antivirus and version if installed

  5. VPN and version if installed



Definitely it is sound something related to your browser cache.

Operation System and version
Windows 10 Enterprise 22H2
Browser and version
Edge Version 116.0.1938.81 (Official build) (64-bit)
Browser plugins if installed
React Devleoper Tools
Antivirus and version if installed
VPN and version if installed

1 Like

Just in case, I tried Chrome with the same account and got the same result.

1 Like

Thank you @Ichiro

I will do a couple tests in order to reproduce this issue.

But how can this be true if i get the same result when i change to a completely different browser?

Operation System and version: Mac OSX Ventura 13.4.1

Browser and version: Chrome v 116.0.5845.187 and Firefox v 117.0.1

Browser plugins if installed: In Chrome, 1Password and XML tree. In Firefox, None

Antivirus and version if installed: Microsoft Defender v 1.397.895.0

VPN and version if installed: Netskope (but it is not activated)

1 Like

it could be cached anyway

Hi guys

Sorry to the late response.
It is ok for you guys if a ask you to restore one of your browsers and remove all the extensions in order to test with a fresh version of it?