Utils package not functional

from utils import *

This line of code is not running. I tried installing utils using pip install utils, import utils and none of these worked. I am not able to run the code because of this.

It is not a “package”: it’s a file in the same folder as the notebook called utils.py. You can download it by clicking “File → Open” to get a “file explorer” view of the files in the assignment. Note that you don’t say which course or assignment you are talking about, since you filed this under General Discussion. You can move it to a more appropriate category by using the little “edit pencil” on the title. You can find instructions about an efficient way to download the files by looking for that topic on the DLS FAQ Thread.

The other general point to make is that there are no “official” instructions for running locally. There are too many different ways to do that, so it’s not reasonable to expect the course staff to cover all the possibilities there (PyCharm, VSCode, Colab, Spyder, …). The course has given you a working environment on the course website. If you want to run in some other environment, then you need to have the skills to figure out how to do that. It’s totally fine to ask questions about it and maybe some of your fellow students will help you out, but the course staff and the mentors may or may not be able to help with that.