Week 1 Lab 1 - Error copying s3 contents

I am getting the following error when executing the following command:

aws s3 cp --recursive s3://dlai-generative-ai/labs/w1-549876/ ./
download failed: s3://dlai-generative-ai/labs/w1-549876/Lab_1_summarize_dialogue.ipynb to ./Lab_1_summarize_dialogue.ipynb An error occurred (AccessDenied) when calling the GetObject operation: Access Denied.

Anyone facing similar problem?

Did you try after sometime, I guess the s3 bucket may have problems to be accessed sometimes…

I have the same error, I am new and have not been able to overcome that error. I just asked the community for help.

I dont know what to say if this problem persists its either coursera or maybe the bucket has issues. @esanina hope you are doing well, is this something that you would like to have a loot at!

@Mongonshagai @Yhobany_Moncayo_Game @Pranathi_Vangeepuram @gent.spah could you please check that you are typing in that command in the System terminal, not just a terminal?

It is not working for me either using the system terminal.

I was able to get it working. The following are the steps:

  1. You must be paid user
  2. Need to navigate to “Lab 1 - Generative AI Use Case: Summarize Dialogue” from the menu and accept the honor code. This enables the Launch app.
  3. Launch app takes you to https://labs.vocareum.com/ where you are automatically logged in.
  4. You need to click Start Lab. Once AWS on the left top corner turns green need to launch AWS by clicking the AWS hyperlink.

Were you also able to import the data within the system terminal? That’s where I got blocked.

@Scott_Miller after running the command that you showed on the printscreen, have you tried to refresh the navigation tab:

Thanks for replying so quickly! I just tried that and there is no response. It seems like the command starts a process, but nothing happens. There is also no error message.