Week 2 : C1_W2_Assignment

Hi every one . Actually I have problem with submmiting my assignment in lab C1_W2_Assignment as although I passed all the exercises I recieve 0 point of each exercise .maybe there is a problem with grading function

First welcome to the community.
As I saw number of other people who have similar case as this one, the issue was that they are not using the updated version of the notebook, secondly try not change anything just replace the NONE with your code to avoid conflicts of words.

If you don’t see any progress, DM to the mentors by showing your code to them, but before that try to do things, I told to do.

Thanks for your help . To be honest I tried to refresh and restart the kernel but unfortunately nothing changed I mean it seems that my changes have stored and I can not back to default codes

The error is incorrect because when I printed the type of function , it was a function class

first of all i will check what’s wrong, but try to remove the code here in the community since its against the community guidelines.


is the line below this sentence working well and producing expected output.

“# add row 0 of the new matrix A_ref to the row 2, replacing row 2”
check the code below this one. and let me know.

I checked it and it worked . I printed the result till its below line and it worked ok
As I said I passed all the exercises

this it the error that I can not fix :


It’s very common to pass the notebook tests but still fail the grader, because the grader uses different data and different conditions.

so better to tag some of the mentors in this course.

Could you please tag them?

@TMosh can you please take a look here or mention some M4ML mentors, if you know one.

Thanks a lot

The NoneType error usually means one of two things:

  • Either you left a “None” in the notebook that you should replace with the correct code.

  • Or you are using an out-of-date copy of the notebook and you need to install the newest version.

I am curious, are you trying to use the “#GRADE UP TO HERE” tool?

Hello all,

I have the same issue:

all tests passed and the grade is 0.

Please, May you help me? thanks

1 Like

Here are two errors. You may have more of the same type.

In Exercise 4, for each of these lines, you should use some function you created in Exercise 3.

The other leading cause of getting 0 points from the grader is if the code you added to the notebook makes the grader crash.

The grader uses different tests than the ones built into the notebook.

I’m having an issue where I submit the assignment after all tests were passed, and nothing is happening. Any suggestions?

I’ve not heard of that issue before.