Week 4 Programming assignment: Distributed Strategy -- Grader Error: Grader feedback not found

All the cells in my code is running without any errors, but when I submit I am getting this error for all the graded functions:

Grader Error: Grader feedback not found

Visit the Discussion forum to see if your peers are experiencing or have found resolutions for similar errors. If the error isn’t resolved in 24 hours, please reach out to Coursera through our Help Center.

I get this error for all the functions:





Please Help!!!

HI, send me copy of the assignment on private, I cannot figure out any problems given these!

Hi Gent,

The problem is that my access to the materials and the assignment has expired today, so I can no longer access the assignment. Let me get in touch with the Coursera Help and see if they can provide me a copy.

In the meantime, here is my lab ID: rvaqatxb. I don’t know if it is useful to you in anyway.


No I cant access your lab ID Rohit. But could have a look at your lab if you obtain it!

I saw your lab, it didnt seem to have any coding mistakes. Are you using the latest lab and default name. You should check if the lab version need be updated and make sure the lab name is as default because the grader wont recognize it. Let me know, if none of these work I might let know the QA team have a look into the issue.

Hi Gent,
On the upper right corner, I did: Help → Get latest version. After that I re-submitted the notebook but I got the same error one again. And for sure I did not change the lab name. Here is a screenshot of the error:

Hi @chris.favila may you have a look at this I am not sure if there is a problem with a grader or lab script so I dont want to raise an issue right now.

Hi Rohit! Did you follow the steps here when you tried to refresh your workspace (scroll to the Refreshing your Workspace section) ?

That should get you a blank notebook. You can then copy your old solutions into it. Please make sure that all the cells run without error in this new notebook. Then click File -> Save and Checkpoint before trying to resubmit.

Hope this helps! If not, please send your latest notebook to me in a DM. Thanks!

1 Like

Hi @chris.favila I sent you the notebook via message. Could you figure out the cause of this error?

Hi Rohit! Just replied to the DM. Please give me a moment to troubleshoot. Thanks!

Hi Rohit! The notebook is running into an error when you try to run all the cells. Particularly, If you run the code cell under the Run the distributed training in a loop section, you will get this error:

AttributeError: 'function' object has no attribute 'distributed_train_step'.

Please try running it in your workspace so you can see the entire error traceback. That should point you to what part of distributed_train_test_step_fns() you need to change. It is just a one liner. By the way, you don’t have to wait 20 minutes to complete this training cell. You can just halt it using the Stop button once you see that it is no longer throwing an error. Then save and resubmit.

Bonus tip: I also noticed a minor error in the train_step() function under train_test_step_fns(). This won’t halt the program but the grader will deduct a couple of points. Please review how you’re computing the loss in the train step. You can use the ungraded labs for reference.

Hope these help!

1 Like

Hi @chris.favila,
Thanks for your help. I managed to correct the errors you pointed out (including the compute_loss). And as you can see below the training is running; I even waited for training to complete with final metrics:
Epoch 10, Loss: 0.142865389585495, Accuracy: 99.75489807128906, Test Loss: 1.2942124605178833, Test Accuracy: 67.64705657958984.

However, I am still getting the same error as before and hence unable to obtain the certificate for the course. Please help!

Hi Rohit. The screenshot seems to say that the notebook wasn’t saved. Please save it first then resubmit. If it still fails, please DM me the latest version of the file. Thanks!

Hi Chris,
I took this screenshot while the model was training. After training completed I saved the notebook before submitting. Anyway, I am sending you the latest copy via DM.

Hi Rohit. Turns out there’s an ungraded cell in the notebook that was modified in your solution. That’s what’s causing the error. Please change this:

def fun1(args=(train_dist_dataset)):

to this:

def fun1(args=()):

Hope it works now!

1 Like

Hi Chris,
Finally it works! Thank you very much for all your help.
Best regards,

1 Like

Glad to help! Congratulations on finishing the course!

1 Like

Hmm see what happens when you meddle with the things you are not supposed to do so. And it takes a long time to figure it out.

Yeah, I think I read the instructions hastily so didn’t quite understand what I was supposed to do. Anyway, thanks @gent.spah for your help!

1 Like