API usage Limit

Hi all, I had just started the course and gave the first few lines of code to run and got an exception saying Usage Limit for API reached and can not move forward. It would help out a lot if anyone could help me with the solution to this issue

1 Like

Hi @AryanHrushikSharma

Welcome to the community.

I run a couple tests and i got no issue.

This is the first course regards chatGPT that you attended to?

Dear Elirod,

Thank you for your response.
Yes this is the first course in ChatGPT. I had debugged the code with Chat GPT and there was no error but when I tried to do it in Jypter it shows up an error maximum API usage limit reached and doest go forward. Hence I wanted to get insight of someone into it, as to why the issue is happening.

Thanks again for your help, have a blooming day.

Aryan Hrushik.

1 Like

Well, maybe we can try to restart the kernel and clean all the outrputs.

You can do that by clicking on the kernel menu at the top of the notebook

Hello @AryanHrushikSharma ,

Try to pause a little between API calls. HIgh Frequency of API Calls might be a reason.
Otherwise, it seems you need to upgrade your API plan as you have reached the limit.

With regards,
Nilosree Sengupta

1 Like

Please let me know if you are still facing this issue. Also, are you running the code in your local?

1 Like

Dear all,

Thank you for your response. I shall write back to you as soon as possible.

Thank you, Have a nice day,

Aryan Hrushik

1 Like

@raj has a good point. if you are running locally, it might be the cause of this issue, because the API calls it will consume your API quota.


Hi all,

i have tried to reconnect the kernel by clearing the outputs and restarted it too but the issue still persists.

By running local do you infer to running it on the jupyter notebook or just like running it offline.
If it is so then I run it on the jupyter notebook while connected to internet.

Thanks for your reply. Here local means running in your local computer (outside of course notebook platform). Whenever, we execute calls to the API via our local system, it calls our GPT API, not the course API one.

Please let us know how you are running the notebook, it will help us to debug the issue

1 Like

Iam using jupyter notebook to run the commands as I could not find the one provided in the course.

thank you

So, the issue is appearing because you are running in local and you have exceeded your quota. I have faced similar issue earlier, it will be resolved when you add payment information. Please note that it has cost associated with it, please refer to the following articles: How can I access the ChatGPT API? | OpenAI Help Center

Alternatively, I will suggest you to post the issue you are facing to access course lab environment. Course comes with the API, using which you can play around to understand how it works for free.

Please confirm whether you are able to see the notebook screen while accessing the course from desktop. Mobile rendering might not work.

1 Like

yes i can see both the windows.
Thank you for the insight too

1 Like

Thank you mentors and team for the help. I am able to use the notebook interface provided within the course and able to run the code without any errors.

Thank you for all the efforts you’ve put in to help me.

Have a cheerful day to you all.


Awesome. Glad it helps you

Hi @AryanHrushikSharma

You welcome. whenever you need we will be at your disposal

1 Like

So, do we need to pay for ChatGPT to get the API working?

Hi @alexmc

If you intended to use on your own environment you can use it for free with a month quota. But you can upgrade your openAI account quota to use it with more flexibility.

If you running from the course platform there is no cost.

best regards

Actually we can use the onboard notebook for practicing. But if you want to have it run on local notebooks then yes there is a limit and we have to pay to extend it.
Thank you.