C1_W2 LAB Submit error

why doesn’t gradd appear, even though I have done it correctly. instead the notification appears “‘w2_unittest’ is not defined” even though I have run it.

What do you mean by “gradd”?
Can you post a screen capture image? That might help explain the situation.


I did the lab correctly, but the assessment was 0 and the notification “w2_unittest difered” even though I had run it.

This assignment and its unit test files were updated on Aug 28.
Do you have the current version?

yeahh I’m working on the current version

Did you also update the utility files? They’re the ones you see that have .py file types when you open the File menu.

Second question. On your notebook, did you ever accidentally delete any of the cells, and then paste them back in?

Also, did you rename your notebook file?

just now I tried to copy the file and the previous file was deleted.

no,can’t submit if file name is wrong

Check your private messages.

One other question: What is your grader feedback for Exercise 1 and Exercise 3?


It appears that you have deleted several lines that mark where your code is to be added.
Lots of the “### START CODE HERE ###” and “### END CODE HERE ###” lines are missing.

I’ll test whether that causes this problem.

You also left a “Grade up to here” tag in your notebook. Try removing that.

still the same


For those following along later:


  • Be sure you do not delete any parts of the notebook that are important - like the lines of code that define a function.

  • And be sure you’re using the current version of the notebook.