C2_W3_Assignment submission error old version

Hi. I’ve done assignment with all unit tests passed. But receive 0/100. And have the message that this is an old version of assignment. I tried click the button “get latest version” and restart the kernel. I don’t know what to do. Help me please!

The assignment notebook and utilities were updated a few days ago.
You need to get the latest version of the notebook, and then re-enter your code.

Please open your current notebook, then open the “File” menu, and post back a screen capture image of what you see there.

I am encountering the same issue. I have passed all the tests. But when i am submitting the assignment, i am getting 0 marks in the 8 questions. It is showing the same error. So, i tried the instructions given in the feedback, downloaded the copy in the my local machine, then renamed the file in the coursera assignment notebook, then click on help and get new file, entered the code all again and resubmitted. Same issue persists.

Try also deleting the .py files that are in the notebook folder.
Then update the notebook again.

The “Get latest version” does not update any files that already exist in your folder.

deleted the .py file as well and all other files. and then got the latest version but useless. same error

I’ll contact the course staff, and see if there is an issue. I’ll report back here when I learn anything useful.

Hi all!

Please note that the “Get latest version” will only replace any file if it does not exist or has other name than it is expected to have. Have you also renamed or deleted the Jupyter notebook itself before pressing the “Get latest version” button?

Since the grader had some changes, you won’t be able to just get the latest version and then copy the notebook entirely. You must work with the new version of the notebook that appears in the workspace. You can just copy the solution from one to another, but it is important that you keep the most recent and updated version of the notebook.

If this is not the case - if you’ve already renamed/deleted the notebook, got a fresh new copy and pasted your solution in the new notebok - then please send me, privately your notebook so I can take a further look!


I am having the same issue. I have passed all the unit tests, and after that, when I submit my assignment, it gives me 0% grades but no message indicating whether it is the old or new version. Can you please fix it?

Please click on the > icon next to Exercise 1, and it will display the grader’s feedback.

Please post an image capture of that.

Hello, I have the same issue.

“You are submitting a version of the assignment that is behind the latest version.
The latest version is 2 and you are on version 1.
To upgrade to the latest version follow the instructions in the reading item called ‘(Optional) Common Coursera Labs Operations’.
This item can be found before the assignment of the first week of the course.
This notebook should be up to date so create a copy of it in your drive, migrate your work to this newer version and submit again for grading.”

How I can migrate to the newer version ? followed the Coursera intructions to use “forceRefresh=true” un the url, it has been reloaded, but the problem persists.

Can you help me ?

As above, I’ve went through the process to get the latest version numerous times now, copying and renaming my original file, deleting the original file, updating the lab, then entering all my information into the new notebook file that is created, same problem exists, no grading and the same error message under the graders feedback to update to version 2 from version 1.

There is an issue with the grader, it is being fixed at the moment, and an update to some of the assignment files will be necessary.

Please stand by.


@campa and @Michael_Gordon You need to delete all the files from the file section and then retrieve a fresh copy. Probably you are missing some of the steps. Please have a look at the below post.

@TMosh Kindly guide them if they have confusion about the same, thank you. They need to update the lab or get the fresh copy of the latest version of notebook as we discussed just a while ago. Make sure to save a copy of your work before you follow the below post.

Also understand that once you have latest version, you need to again manually write the codes.

Let us know if the issue still persist!!!


1 Like

Did you mean that?

I’m not sure what you’re referring to.

I mean, all exercises unit tests are passed, But at the end, while submitting the assignment, It shows 0% grades for all of the exercises. What is that issue?
It gives me that error:

I think this means you need to get the newest copy of the assignment ipynb file, which was checked-in earlier today.

Try the procedure given in Deepti_Prasad’s post from earlier today (via the “Math for Machine Learning FAQ”).

You will need to re-enter your code from your old notebook into the new one, by copying each code segment that you added.

Yeah, its’ done now. Thanks.

That’s good news!

Thanks a lot! It works.