C3-Week 5 Assignment: Lab not starting at all

In the Week 5 assignment, when I click Start Lab I get this error:

Lab failed on 2022-11-25 09:12:37 -0500: Qwiklabs Startup Script error: Error executing terraform apply [Error: Error waiting for instance to create: The zone ‘projects/qwiklabs-gcp-02-2f7e494dcfcf/zones/us-central1-c’ does not have enough resources available to fulfill the request. Try… Any credits or tokens you used to start this lab have been refunded.

I have tried a few times but have not been able to start the lab even once so no chance of quota exhaustion. Since the lab does not get started I cannot even change the zone etc.

Does this help?

I could not try this solution as the error happens when I click Start Lab and before google console is available.
Can I change the zone before starting the lab?

Please contact qwiklabs help.

This is my 3rd day with this problem. I have contacted the support but they always gave the same answer “we’re looking into it please be patient and thank you”.


I’ve notified the staff now.

Hi Nabeel and Omar! Thank you for bringing this to our attention. I can replicate the issue and will escalate it to our partners. It might take a while though because they are on Pacific Time. They might not see our report till tomorrow during work hours. Rest assured that we will monitor this closely. Thank you and sorry for the inconvenience.

I am also experiencing the same issue. No issues with restarting other (completed) labs from previous weeks.

I’m also experiencing the same issue. THe lab does not start at all.

Yes, I am also experiencing this issue. Contacted support and get the same response that they are looking into it. Given that some other labs were failing to create clusters within the lab on any us-central zones I think it is a problem with those zones specifically… let’s hope it gets resolved soon, I am 98% completion lol

I also encountered this issue in both this assignment and the first one in week three of class 4. I have reported the issue to the customer service and they said they are fixing the issue and will update me as soon as they fixed it. But I am not sure how long they problem will be fixed. I wish it could be fixed up fast but it will be really a painful problem if they spend weeks to fix it…

Me too, I reported it last Thursday, but still no improvement. There is about 3 labs from course 3 and 4 that I can’t complete because of this. Coursera should extend our subscriptions for free if it lasts any longer

Hey chris, any work around for this problem? My certification and others likewise are bound by this problem.

Hi everyone! A temporary fix has been pushed and you should be able to get into GCP. I just tried it and it took about 4 minutes before lab resources were provisioned. Once inside, you can complete the lab but the last two checkpoints might not detect the models you’ve deployed (even if you can run predictions from them). Thus, you might only get a maximum score of 60/100. This will still be enough to get a passing mark and complete the course. Hope this helps! Thank you!

temporarily marking this as the solution for visibility

1 Like

When clicking on “Workbench”, I got this error:

You do not have sufficient permissions to view this page

Hi Tran. This usually happens when you are using your personal Google account for the lab. Sometimes it accidentally switches so please make sure that you are using the Qwiklabs credentials. One way to avoid this is to do the lab in a private or Incognito session.

Also, please check that you are using the Vertex AI Workbench. There are other workbenches in GCP (e.g. Dataflow) and some learners misclicked on those when using the search bar.

Hope this helps!

1 Like

I just tried the last two tests they still do not work…

Hi Dong! Apologies for the delay. There were some changes in the backend last week which have now been reverted. You can try again if you wish to get the perfect score. Thanks!

Hi Chris,
Thank you for reminding me. I just tried and all tests were passed.

Awesome! Thank you for confirming, and congratulations on finishing the course!