Cannot complete course. Improper EC2 instance type error in Week 2 Lab (Fine-tune a generative AI model for dialogue summarization)

I do not have permission to use any instance type other than ml.t3.medium which is 2 vCPU and 4GiB of RAM.

Kernel consistently restarts at this step:


I have tried multiple times and got the same kernel restart issue.

I need an instance type with 8 vCPU and 16 GiB RAM.

Otherwise, I cannot officially complete this course.

Can some one please address this issue?

Thank you!

Edit: Fixed for me. I was able to select the correct specs when I started up a new instance today.

Original post:

I run into the same error, and I think it’s because the kernel keeps crashing and restarting at trainer.train()
Meaning that all previous code blocks are no longer in memory and you’d have to run everything again for variables and modules to be defined.

The reason I think trainer.train() keeps crashing is because I can’t seem to be able to select an environment that can house the model and dataset. The lab asks for a 8CPU 32GB RAM environment.

The closest I can select from the dropdown is 4CPU 16GB, but then get an access error saying I can’t use that instance. (Note: I can’t scroll further down in the “all instances” section).

Please advise on how to fix this issue, as it’s currently preventing me from finishing this week’s lab.

I got stuck with same issue, now its erroring out and neither coursera or Qwicklabs are able to solve this
I have tried to set instance type to XLarge earlier and tried to restart the Lab three times, later it errored out stating “AWS account deactivated at 2023-10-21T15:36:16-07:00”

when contacted with Qwicklabs, they say they stopped supporting AWS going to Google cloud, Cousera is not responsive either