Cannot create post nor topics in course site

Dear DeepLearning.AI community and admins,

I have started the Deep Learning Specialization and would like to open up a question. Unfortunately, it is impossible for me to open up a new topic on the Course site, nor can I post something to an already existing topic.

I already read through the Discourse New User Guide but nowhere do I find information on any restrictions regarding opening up a topic or replying to an existing one. Any help will be highly appreciated, thank you!

The first thing to try is the equivalent of the “therapeutic reboot”: just logout of Discourse and then log back in again. It’s possible your account is in some odd state.

If that doesn’t work, then the next theory would be that Discourse seems to have fundamental mechanisms of trust that start out very restrictive and then loosen up as you do activity on the system and they can see from your behavior that you’re not a threat. It would be worth just reading a bunch of posts in the subcategory of DLS Course 1 and see if the “New Topic” button eventually is no longer “greyed out”. My guess would be that they might let you reply to an existing post before they light up the “New Topic” button. See if you can find a topic that is relevant to some question you have and try to post a followup. Try using the search engine to find some relevant posts. It seems to work pretty well.

Let us know if that works or not. If not, we’ll need to call for help from the course staff.

Dear @paulinpaloalto,

thank you very much for your help. The “therapeutic reboot” unfortunately did not work.

I also read through some posts and still cannot open a new topic in a course. I can’t even reply to a post, except for this one, obviously. However, I can like, vote, bookmark and flag posts. What is even stranger is that I can share a post, and then by this creating a new topic in a course I can’t create a post the “normal” way. I attached two screenshots to illustrate this. I actually didn’t click on the “Create Topic” button in the second screenshot beacuse I didn’t want to spam. So I don’t know if in the end I am prevented from opening a new topic this strange way.

One other theory would be that this is an IT problem of some sort on your side. E.g. maybe you are using a browser that doesn’t work with Discourse for some reason or you’ve got some security settings on either your browser or your local net that are preventing some URLs from working. The browsers that should work are Chrome and Firefox. What are you using?

I’m having the same problem. I’m using Firefox.

This is very frustrating. The old discussion system built in the course seemed to work fine. I started C4_W3_A2, but all the answers were already filled in. All I want is a clean notebook so I can do the assignment properly.

Hi, Justin.

I reported this thread to the staff yesterday. I’m hoping one of them will be able to figure out what is wrong. My guess is that you just need to do more activity on Discourse before they unlock more capabilities, but it may be more complicated than that.

I can see from your user stats that you have looked at quite a few posts. Have you tried “liking” one of the normal course topic posts?

Can you show us a screenshot of what you see when you look at someone else’s post on one of the actual course subcategories? E.g. here’s what I see:

Do you see the “Reply” entry and the little “three dots”? If I click the three dots, I get more tools I can use:

In my profile, I’ve confirmed that I’m a “Basic” user and should be able to create a new topic. The guide doesn’t say anything about having to read or like a bunch of stuff to be able to start a new topic.

It seems I can create a New Topic in the General Site Feedback forum, but not in the DLS forum.

Hi, Justin.

Sorry, I was grasping at straws. It looks like my theories were all wrong. One of the staff members looked and her analysis was that in @MarcelH’s case that he was initially registered for a different specialization and then added DLS to his account. But that has no effect on your Discourse account.

It looks like we need manual intervention from the staff to add you to the DLS group on Discourse.

Stay tuned!


Hi @MarcelH @Justin_McBride ,

Are you able to create topics now in DLS or still facing problems?

Hello @agparth,

my issue has been solved. I initially started the “Machine Learning” specialization, but did not register for discourse during that course. Then I started the DLS specialization and followed the instruction of the first week of the first course to register for discourse, but wasn’t able to post or reply to posts in the specialization. After the manual intervention of a staff member, I am now able to participate in the discussions of the specialization.

Glad to hear that it got resolved and apologies for the inconvenience :neutral_face:

No problem, thanks also for your and @paulinpaloalto 's help! I hope that the staff can figure out how to automatically enroll participants despite their previously visited courses, such that all new learners can actively take part in the discussions right from the start.

It looks like I can create a new topic now. Thanks.

I can create new and interact with existing topics in the AI4M individual course weekly topics, but am read-only at the AI for Medicine top level category. I completed the first two classes in May 2020. Welcome your thoughts and suggestions.

Perhaps I’m just missing your point, but I think the top level categories are different. All you can do at that level is create new first level subcategories and I’ll bet the ability to do that is reserved to the course staff. E.g. even with Mentor status for DLS, the “new topic” icon is greyed out for me at the top level of Deep Learning Specialization.

Thanks for the prompt reply. See for example this thread

It is at the AI for Medicine category level. I can read it, but can’t reply to it. Someone (doesn’t appear to be staff-level user) created the thread at that topic level but I can’t.

Same question asked a couple of weeks ago here…

It’s there now but I think it was moved

It looks like AIM is set up differently. In DLS there are no conversations at the top level, just subcategories. In any case, I am not a Discourse administrator, so I have no idea what gives here. We need to appeal to a Higher Power: @mubsi or @agparth, would one of you have time and be kind enough to take a look at the configuration of the AIM category? Or can you recommend someone else on the DLAI staff who takes care of AIM? Thanks!