Cannot open Labs

I opened it up, ran some cells, and went away for a bit. When I came back and tried to refresh I can’t open it again.

This has happened for labs prior, and sometimes it randomly worked again. However it’s a major inconvenience and I’m wondering if there’s a fix for it?

for search optimization: the top has in red “Failed to fetch” and the whole page says

" We’re having trouble preparing your lab

Hit refresh to try again and make sure you’re logged into Coursera"

So I’m wondering if this has to do with coursera, having some broken thing with linking with jupyter notebook?


Hi there, I thought I’d mentioned I am also having this problem and cannot figure out the solution to get the lab to open. Hmm

1 Like

Coursera is having a technical problem.
Please report the issue to the Coursera Help Center.

1 Like

Closing the thread, because we have plenty of reports about this already.

1 Like

Hi @Robert_Collett & @danielhamg ,

Coursera is having technical issues because of which the Labs are down. They are aware of this and working on resolving it. Please follow this topic for updates.


1 Like