Failed to Fetch error for labs


I am getting error opening the labs. This is the error message “We were unable to retrieve a launch URL. Please make sure you are logged in to Coursera, and have access to this lab.”. Please help.

This is happening after I cleared history on Google Chrome.

Hi @suvarnabhonde, I suggest you to close all the coursera webpages on your browser, then open a new browser to go to the coursera website, and try to login again (if you have already logged in, maybe you can log out first)?



Thanks for your response. I tried as per your suggestion. But the labs are still not opening for me. Any other suggestion will be highly appreciated.

Hi @suvarnabhonde,

Please check this out and see if this is your case?


Hello. Yes, I have paid for the specialization on Jun 22. Already past my refund window. In last week I was able to open the " Python and Jupyter Notebooks" optional lab. I also downloaded the notebook. But now, none of the labs are opening for me. :frowning_face:

Do you mean that you have an active subscription but you are not able to assess the lab?


This is what coursera’s help says

You’ll only be able to access your Coursera Lab assignments and Jupyter Notebooks if you have a paid Coursera membership. If your subscription ends, you’ll be put into audit mode and won’t be able to access them

If you think you have an active subscription but you are not able to assess the lab, I suggest you to contact coursera ASAP. This is the link to the coursera’s help center and also the instructions of “how to contact cousera”. You can find a link to their contact form in the bottom.


Yes. Its active subscription. This is what I see “Certificate: Earn by Sep 20, 2022” on the My Purchases page. I shall check the link you have shared. Thank you so much :slight_smile: