None of the Lab is opening in week 1 of MLS Course 2. please help

Upon clicking the button, it is showing: Error

We were unable to retrieve a launch URL. Please make sure you are logged in to Coursera, and have access to this lab.

Please help. i tried reloading refreshing. nothing worked. unable to access the lab… It is also showing Failed to Fetch.
None of the labs is opening. all showing the same. please help.


If you see this error:

Quoted from mentor @Kic (source)

  1. You were enrolled onto the course under the 7 days free trial option and it is now expired. If this is the case, you need to enrol to the full pay option to gain access to the assignments.
  2. The system experienced a hiccup. If you logout and logon again, it would normally solve the problem. You may also like to try a different browser to see if it helps.

Note that besides a different browser, you may also use your browser’s incognito mode to login, and see if it makes a difference.

Quoted from Coursera’s Help Center (source)

You’ll only be able to access your Coursera Lab assignments and Jupyter Notebooks if you have a paid Coursera membership. If your subscription ends, you’ll be put into audit mode and won’t be able to access them

If you think you have an active subscription, but unable to access any Coursera Lab assignments and Jupyter Notebooks, please contact Coursera ASAP. This page talks about how to contact Coursera with Chat or by a contact form.

A learner shared that the error is gone when the assignment was opened on another computer. (source)

If you have an active subscription, a quick thing to try, even before contacting Cursera, is clearing the browser cache.

Yes, I do have a paid Coursera membership for the DLS 5-course sequence, and it ends on September 02 for course 4 and 5 of the sequence. I completed the first 3 courses with no problems at all in accessing the course material, including programming assignments.

I will try a different computer as well as a different browser to see if it solves the problem. Thanks

1 Like

I tried clearing the cache and cookies - didn’t help, getting same error.

I also tried a different laptop with Linux, and that didn’t help either - same error.

Not sure what to do at this point.

I suggest you to contact Coursera.

Hi, I have existing subscription for this course and have been using google Chrome to access all the videos and Labs so far. Everything was fine. but recently, to this moment, lab is not accesible via google chrome. I have refreshed chrome, updated it. cleared cookies and done everything possible. but the problem remains. However, the labs are accessible as normal through Mozilla Firefox… so, currently using firefox to access the labs. kindly escalate and resolve the issue if possible. thank you.

Hi @souravBiswas,

Please contact Coursera to discuss your situation.