Cannot see the Jupyter Notebook

Now it is not possible to see the jupyter notebook in the programming assignment 1. I guess this is because people are working in the submit button problem. Is this the case?

Hey @jfbotero ! Are you still facing this issue ? If so, which Week’s first assignment is it ?

Hello Mubsi.

I’m facing this issue with all the assignments of the course, I do not know what happens. Before, in the instructions tab of the assignment I was able to access to the Jupyter notebook. Now this is not possible and I can’t see the instructions and I cannot access to the notebook.

It is a shame that I cannot attach a screenshot here. But it seems that all the access to jupyter notebooks was disabled to me. I have tried using different browsers and it is the same.

Hey @jfbotero you should be able to attach screenshots now. Could you please try again ? Thanks

If it still doesn’t work, you can DM it here on Discourse

Yes, you should be able to upload a screen shot. Use the little “picture” icon in the toolbar on the reply. Here’s what I see when I click into the “Grades” item on the left menu:

You can see I get the “Work in Browser” button for the “Initialization” assignment. Is that what you are missing? Or is it something else?

Here’s a screenshot that highlights the “picture” icon for uploading an image:

1 Like


@paulinpaloalto this is the image I saw before. The thing is that I performed and run the assignment but could not find the submission button. I created a post here and I was sent to ask to coursera help center. There, I had a chat with a support person, that told me that she reset all my deadlines and after that I entered to the course and can’t go inside the programming assignments.

I see the following:

It is the same for all my programming assignments.

That means you are in the old version of the course. Click the left bar to expand it. Then you should see a separate menu item with “Lab” in the title that will get you the “Open Lab” button.

Here’s a screenshot showing where to click to expand the left menu:

If you expand that, then this is what you probably will see:

Note that there are two entries for “Initialization”: one with “Lab” in the title and one with “Programming Assignment”. In the new course there will only be one entry with “Programming Assignment” in the title. In the old course, you need to click the “Lab” entry in order to open the notebook.

1 Like


Now it seems to work for me. Even the submission button is working. However the labs are a little bit different. Can I change to the new version of the course or should I stay with the “old” version?

Juan Felipe

For Course 2, the major changes are:

  1. New graders in all assignments.
  2. The TensorFlow material in Week 3 is all upgraded to use the latest TensorFlow 2, which is quite a bit simpler to use than TF1.

The only changes to the lectures are the ones about TF in Week 3. Whether you want to upgrade is up to you in the short term. Eventually there will only be the new version, but I’m not sure when that actually happens. The thread from Mubsi has information about the problems that students are having with switching to the new courses. It might be better to monitor that thread until they get the problems resolved before trying to switch.

1 Like