Unable to find Submit programming assignment - Course 4 - Week 1


I have completed the programming assignments for week 1 but the “Submit Assignment” option does not show up on the Jupyter Notebook.

Also tried the fix mentioned in this topic with a similar problem but it did not work. - (Unable to submit Course 2 Week 1 assignment)

Would appreciate if I could get any guidance on how to submit or fix this.

Thanks in advance.

Try restarting the kernel, and then re-loading the notebook.

Right! Note that the thread you pointed out was to the MLEP course, not DLS. I assume their notebooks work the same as ours. Note that there is a topic about this on the FAQ Thread for DLS that describes what Tom suggested in more detail.

Thanks for your response.

I tried this a couple of times and it did not fix the issue.

Maybe you are using an obsolete version of the notebook file. Is there a newer version in your workspace that you aren’t using?

I’ve updated the notebook to the latest version, still does not work.

Has this ever worked for you on any other notebooks in Course 1 or Course 2 or is this the very first time you are trying this on any of the course notebooks? I’ve seen a couple of cases where the problem was that the student’s account was in some kind of weird state. The solution was to talk to the Coursera Help Center and have them “unenroll” you from the course and then “re-enroll” them. If this is literally the first time you’re tried to open a notebook, then it might be worth doing the “unenroll” method.

Sorry for the late response.

This worked for me!