Course 4 > Week 3 > U-Net GRADER DOES NOT WORK

Hello guys!

The latest update of the U-net grader unfortunately still not working correct :frowning:
The result of correct submition is still 0/100 (all tests passed and all cells compiles as they should)

This does not help either:

  1. P​ress Kernel → Restart & Clear Output
  2. P​ress File → Save and Checkpoint)

T​he grader output is:

“Cell #3. Can’t compile the student’s code. Error: IndexError(‘list index out of range’)”

Please fix this :slight_smile:

Hey @anshi, the graders are functioning properly, please don’t have any doubts about that.

This error is related to your notebook.

I’d recommend SAVING YOUR WORK ON YOUR LOCAL MACHINE or rename the file, and get a fresh copy of the notebook from the “Help” menu on the top right. You might have unknowingly changed some code which you shouldn’t have had in the notebook.

Let me know how that goes.

1 Like

Everything worked fine, thank you!
But I’m steel confused about what happened with my original notebook :))

Thank you for help

maybe you can compare your old and new notebook and also let us know what do you find different.

I got this exact error and it turned out the solution was this one by Meir.

In “Cell 3” - i.e. the third executable cell, just under " Check out the some of the unmasked and masked images from the dataset", I had changed the index N of the sample image to 10. This worked in the notebook, but broke the grader.

1 Like

Thank you @geomacy for this. I needed to investigate it, but you saved me a lot of time!

1 Like