Docker command not found though Docker is installed

I am trying to follow Docker related instructions here.

I have Docker installed on my machine. But when I run the command “docker pull deeplearningai/mlepc1w1-ugl:jupyternb” I am getting the error “zsh: command not found: docker”.
After searching online it felt like it could be because Docker is not on my Path. So I tried running following command:
export PATH=$PATH:/usr/local/bin/docker
Export command ran with no error. But still i am getting the zsh: command not found: docker`" error. Can anyone help?

Place the docker file in your main drive or where your jupyter notebook looks to locate the docker file (like for my systems it always the local drive C).

Make sure the docker file and notebook you are working on is in the same folder placed in the drive where it can read the docker file. The path you selected probably isn’t the right place where the docker file should be.

Let me know if you still have the issue.

Based on the image shared, seems like your assignment is in your document folder and you are searching the docker file in bin, which is the discrepancy in the path recalled.


Thanks for the response. I am afraid, I still might need some help here.
So should I move my assignment directory to bin folder? Won’t that mess up the docker installation. Or should i move some docker related files (not sure which ones) to my assignment folder?

My understanding was that I should be able to run “docker” command from any folder in my file structure as I have docker installed and it has been added to the PATH. What am I missing?

I am not a programmer, so you might have to simplify things for me a bit.

Place the docker file where the assignment file is placed which is in your system I suppose Document folder. But make sure to create a new folder in which all the necessary files like docker command as well as the assignment notebook which are writing codes are in one folder.

If the above step doesn’t work. Next step would be to place the folder which I told you to create in local main drive of your computer. Then write the path as per your jupyter notebook requirement.

In case you are still not understanding, then send me DMs with image both your folders are placed. Then send me the code which you wrote for the path viA personal DM.


Hello @saurabhshrivastava,

Can you try the below link

Then download all files by click lab files.

The link I shared is the one which is compatible with Coursera environment too. But the plus point is, it doesn’t require you to download the docker command which is creating the issue for your local Jupiter.

Try this once. Follow the same instructions as mentioned.

  1. Click the link I shared here, that will open the ungraded updated lab version compatible in Coursera environment.
  2. Click on the Lab files === Download all files. (before doing this step, make sure you have deleted all the previously downloaded files as it can confuse the path.
  3. Once you have download the folder, relocate the path as it might be in Document or Downloads folder of your computer. the path would follow your local main drive/then either document or download (wherever you saved or downloaded whole folder)

Most probably that docker path command won’t be required as I checked for this lab the necessary files are with the image folder in the files.

The only important don’t miss is, do not download files separately. Download the whole folder, so it helps you ease in moving all the necessary files with the assignment file to be in one place.

Let me know if this could resolve your issue.