Getting the premission denied error and jupyter notebook doesn't save, also I don't see the submit assignment button

Hi, Unable to submit assignment DLS C5 W1, getting permission denied error when saving the file.

Same for DLS C4 W1 assignment 2. Cannot save / submit. Restarting kernel did not help

same for myself - getting message on the kernel: Permission denied: W1A1/Building_a_Recurrent_Neural_Network_Step_by_Step.ipynb

This won’t let me save or submit the notebook

For context, loading notebooks now gives the following message, which I never previously experienced:

The instructor has updated this lab

This lab has been updated with the following changes from the instructor

Mar 3, 2022

W1A2: Updated instructions for Ex 2 (in Step 3)

Mar 3, 2022

W1A2: Updated instructions for Ex 2 (in Step 3)

Mar 28, 2022

W1: Added “Important Note on Submission to the AutoGrader” section in the Introduction section of the assignments.

Mar 28, 2022

W1: Added “Important Note on Submission to the AutoGrader” section in the Introduction section of the assignments.

Mar 28, 2022

W1: Added “Important Note on Submission to the AutoGrader” section in the Introduction section of the assignments.

Mar 28, 2022

W1: Added “Important Note on Submission to the AutoGrader” section in the Introduction section of the assignments.

This will not override your existing files.

That is not an unusual message, but it only happens when the notebooks have been updated by the course staff. You probably will find that the notebook that opens is clean and has none of your previous work. The message should give you the name of the notebook that has your saved work. You can open both of them in parallel and “copy/paste” over any completed work from the old version to the new version. Note that you don’t just want to rename the old version to the standard name, because then you lose whatever bug fixes the course staff just made.

Thank you for the response, however it doesn’t seem to be addressing the error. I had this issue prior to having any previous work, and I don’t see the option for a previous notebook. I’m currently seeing this:

As to the permission denied message, I tried both saving and submitting the new clean notebook with some changes copied over to it and it works for me.

This is the first assignment in Course 5. Have you taken any of the previous classes? Were you able to work with the notebooks there or is this your very first time using any of the course notebooks?

I’ve taken the previous 4 courses in the specialization and had no issues, certainly none like this. I’m redirected to the notebook from the Coursera assignment " Building your Recurrent Neural Network - Step by Step", upon clicking “Work in Browser”. Then I get the notebook that I sent the screenshot of.

As you can see, there is no option to submit within this notebook, and saving is not possible due to the permissions error. Restarting kernel, refreshing, etc. has not solved this issue

I have no idea what would cause that, but I can think of two theories:

  1. There is something wrong with the way your account is set up. How are you paying for the courses? Is it a subscription to the whole specialization? Or are you doing it one course at a time?
  2. There is something generic wrong on the servers right now.

Option 2) may be serious as I see a number of messages like yours from several students in C4 and C5 just over the last hour or so. E.g. there are three of you on this thread having similar sounding problems all at the same time.

I will try to raise the attention of some of the course staff and see if they can help.

I see,

  1. Given that I can still complete quizzes and was completing labs as early as last night, I’m hoping it’s not a subscription issue. I paid for the whole specialization subscription on March 17.

  2. FYI that this is occurring to all notebooks I try to access in DLS course 5, it may be a more persistent issue.

Thanks for your quick help and response though. Hopefully it can get resolved shortly

I just want to jump in and say that I am having the same issue on C4_W1_A2 assignment (Convolution Model Application). I am unable to save, I get the permission denied message, and I have completed the assignment three times in the last two hours trying to get it to submit. I see the submission button, but it get stuck and wont complete the submission.

Hello @Nathan_Villicana-Sha!

As you can see that many students facing this issue, so we request you wait for a while. We informed the course staff to look into the issue as soon as possible.


The same issue for me on DLS4 Week1:

Still getting this on Course 4 Week 1 assignment 2. Could potentially be related to training in the notebook since that’s when I start seeing the Permission denied error. However I did this quickly since i saved my work to a text file from yesterday so the workload vs permission denied could be a coincidence. Would be nice to see this fixed soon. Seems like a general infra issue.

I’m experiencing exactly the same problem in working on a coding assignment in Jupyter Labs in DLS1 (Neural Network and Deep Learning) Week 4. Chatted with Customer Support but they don’t seem to know the source of the problem. Instead, I was directed to the community board. Seems like a back-end issue with the server…

Exactly. Unfortunately we are at the mercy of Coursera in this case. The mentors reported it to the Course Staff and they have reported it directly to Coursera Engineering, not through the normal customer support. But we have not gotten a solution from them yet … Sorry, but there’s not much else we can do at this point but wait.

Going through the same issue here myself for Course 4 W2. Will wait. Thanks for reporting it back to the engineers.

Hi all,

if it’s any consolation, the problem also occurs in other course assignments on Coursera, outside of this Specialization. I just tried to work on an assignment in the “Applied Data Science with Python Specialization”, and got the same error.

Let’s hope they can fix the issue quickly.

Same error for me too. Hope it will be fixed soon.

Same error for W1 A3. Please help rush coursera to fix this asap. Everyday is a hit to our wallets :frowning:

Coursera technical support says that this error it’s not in their scope. It must to be fixed from Very bad support imho. Or very bad course. One of the two :slight_smile: