Grader Issues + Exercise 6

I’ve been having issues with Exercise 6 so I ran the code with “# grade-up-to-here” included in Exercise 5. When I run that, I get a 100% on all sections except Section 6, as expected. However, when I run the entire book without “# grade-up-to-here” included, I get a zero on everything with the same error :
"There was a problem compiling the code from your notebook. Details:
name ‘w2_unittest’ is not defined "

How do I fix this? Exercises 1 - 5 run absolutely fine if I run with # grade-up-to-here in
Exercise 5, and for some reason fail when this code is not included.

For Exercise 6, I got really lost in the weeds and am now unsure what I was supposed to even be calculating. How can I retrieve the initial instructions for this problem without restarting the entire assignment?

Hey @Raquel_Destefano

Well if it works with “#grade-up-to-here” command, did you try to put it at the end of exercise 6 as well?

@Jamal022 Yup. Fails with the same error.

@Jamal022 See link below. Looks like the same issue has been reported by many users and no public solution has been posted since the issue was “first” reported in March (first reported via this thread, there may be previous reports)…that doesn’t bode well. The bigger issue to me is that I’m not sure how to make an attempt to “refresh” the instructions for Exercise 6 without clearing the entire assignment. Can you provide the code for that?

Can you dm your notebook to see what could have gone wrong

Hello Raquel,

Please replace A_system to A_ref for like this
#swap row 0 and row 1 of matrix A_system:
#A_diag = SwapRows(A_ref,0,1) in exercise cell 6

After this you need to replace all your A_system with A_diag for the exercise cell 6.

Run the cell.

Let me know if the issue is resolved. If not share what output or error you get after this correction