Grading Error - c3_w2_ex2

Hello there,

I’ve tried to submit my file several times for the second practice lab, but keep getting this error?

Cell #2. Can’t compile the student’s code. Error: FileNotFoundError(2, ‘File ./data/content_top10_df.csv does not exist’)

It’s odd as the table output does work within the code/notebook.

Let me know what needs fixed here to make this correct.

Hi Kevin, thank you for sharing the problem here. I will contact the course team about this and then get back to you later.


Hi Kevin,

Welcome to the community and thank you for reporting! The team is now working to fix the grader. If you need to submit it now though, you can opt for this workaround to avoid the compiler error you’re getting:

Step 1: Comment this cell that reads and prints the CSVs

Step 2: Comment this cell that prints the genre table:

Step 3: Comment out the call to print_pred_movies()

Step 4: Comment out the call to print_existing_user()

Step 5: Save the notebook.

Step 6: Submit the assignment. It should now be gradable.

Please do the steps above only after you have completed the lab and you get the expected output. The team will fix this asap so you won’t need to comment out the code cells.

Hope this works for you. Will update this thread when the fix has been deployed. I’ll mark this temporarily as the solution so other learners who can’t wait for the fix can get a grade. Thank you and sorry for the inconvenience!

1 Like

Hi! The bug has now been fixed. The grader should now work as expected and you don’t have to comment any code cell. Thanks!

1 Like

Hello! I am getting some errors while submitting my assignment.
When I click on “Submit Assignment” it says, " Submission successful" but when I click on “View Grades”, after the process of “Grading your submission…” it says “Submit your assignment to receive a grade”. I tried to submit it several times but every time, get this message. . .

HI @saifkhanengr,

Thank you for your report. This problem seems affecting many learners and we have notified the course team about it.

I`m still facing the same problem. any suggestions

Hi Yasitha! Welcome to the community! Based on the error message, you might have renamed the notebook and tried to submit that. Take note that the grader only recognizes the notebook with the original filename (i.e. the one that opens up when you start the lab from Coursera). For other troubleshooting tips, please check this topic. Hope this helps!

I will check on that. I didn`t change the name. Will a message like this affect the grader.

It depends on the exercise but usually no. Hope the tips in the other topic will resolve the issue!

Refreshing the workspace worked.

Thanks a million :smiling_face_with_three_hearts:

1 Like

Great! Glad it worked!