I can only download two of the .ipynb's

Are the other ones locked? Memory and Agents are the only ones I could download on both Firefox and Chrome on Windows.

Hi @Nobu_Taka

Welcome to the community.

A workaround is to download the course files by clicking on the jupyter logo at the top left

Best regards

1 Like

? That does not download the course files, actually it does nothing.

It works for me

What module are you attending?

here it is a example:

1 Like

Another workaround is to running your browser on incognito mode

I’m having the same issue, can’t download the .ipynb files.

Clicking the Jupyter logo on the top left lists the files, but that checkbox doesn’t give me any option to download the files.

image

I can click the .ipynb files in that list but it just opens it in Jupyter, and none of its download functions work.

I tried incognito mode, but it behaves the same for me.

Are we missing something here, or is the site broken?

1 Like

click “edit” in the screen that you have posted, to get to the screen that I am showing here. The “download” option in the file tab here WILL work.

2 Likes

from here you click the “Edit” tab which will display a window with the json representation of the notebook. There will be a “file” tab on that edit window which will offer a “download” option which WILL work :slight_smile:

Hi @glotrec

welcome to the community.

Thanks for your colaboration

1 Like

Thanks for the workaround, that allows the file to be downloaded.
Note, however, that this workaround still doesn’t allow you to download the notebook with your latest changes on it - it just downloads the file as it was when you were last able to save.

So I dug a bit deeper into what’s going on, and the download issue only seems to happen when I’m unable to save the notebook.

In the screenshot below, I was able to save the notebook and the download was still functional.

However, after running several more cells, I was no longer able to save the notebook and the download function also stopped working.
You can see the save error on the screenshot below:

To reproduce the issue, you can try running all the cells in L6-Agents.ipynb, and then trying to save or download it.

Could it be that the issue is linked to the file size of the ipynb? The more cells we run, the bigger the file size, possibly going over the max allowed file size for a particular notebook for it to be saved…

Hopefully this helps with figuring out a fix for the problem.

2 Likes