Notebook (.ipynb) download fails silently

I blew out my OpenAI api key limit, so I’ve been working through labs using my own key and running notebooks locally.

In the above notebook L4_Chains.ipynb, in the DLAI learning system, embedded in the UI, when I select File > Download As > Notebook (.ipynb) it pops a new tab, but the download silently fails: no file is downloaded and no error message or other indication that anything has gone wrong.

I also tried using File > Open which takes you to the file browser, opened the notebook directly in my browser and attempted the same, and got the same behavior: silent failure.

I also couldn’t find an option to download in the file browser.

In the end, it appears because the Notebook kernal was active (running?) the download failed and the download button was not active in the file browser. Once I interrupted the kernel, the button in the file browser reappeared. Presumably this would have also allowed me to download from the notebook itself, too.

So I’m sharing here because I didn’t see this referenced in any other topics that have been started. And I solved it myself after I started typing, so no need for anyone to reply. :slight_smile:

1 Like

Hi @pchittum,

What you described above is a bug I have seen with the Jupyter notebook. Whether it is in our platform or on Coursera. Sometimes the file is download using File --> Download, sometimes it downloads the notebook in a different extension (for eg, .json). And sometimes it just fails.

I have found the second procedure you have mentioned as the most helpful, when it comes to download notebooks. But yes, you have to “shutdown” the notebook first in order to download it.

These would be the steps:

  1. File --> Open...
  2. Click the checkbox next to the notebook, it will then show you a Shutdown option, click that. This will turn your notebook icon from green to grey.
  3. Next, click the checkbox next to the notebook again, and now you’ll see the Download option.

Best,
Mubsi

5 Likes

I was able to successfully download the notebooks using the following method:

  • File
  • Download
  • Right click .ipynb and “Open in New Window”
  • In the new window, regular File > Download > as .ipynb

Took a few tries to get it working, and some notebooks were stubborn - but worked in the end.

1 Like

This worked for me ! Thanks

1 Like

I’ve been able to download by stopping the kernel, waiting for confirmation that it actualyl stopped and then the File → Download menu opens a new tab but allows you to actually download the notebook.

1 Like

@Mubsi thanks your instructions were super easy
@pchittum thanks for brining this up and starting the answer!

1 Like

Thanks, @Mubsi This option worked for me!

1 Like