Jupyter Notebook will not run at all

Hi all,

I have some trouble with the first Juypter notebook. When I start it, I get

“A connection to the notebook server could not be established. The notebook will continue trying to reconnect. Check your network connection or notebook server configuration.”

Also, the cells do not execute when I run them. I just get the ‘waiting star’.

I tried restarting the kernel but to no avail. I tried two different browsers and even a different PC (in the same network, though). Can anybody help me with this?

It’s hard to know for sure, but this sounds like some kind of IT problem. If you are on a work or school network, they may have proxy or firewall rules in place to block connections that don’t look like standard “accessing a website” style connections. It sounds like you’ve done a thorough job of experimenting so far, but the one more thing to try would be to either use a VPN or try it from a public WiFi network and see if that makes a difference. If it works on a different network, then maybe you could talk to your IT folks and get the Jupyter server connections “white-listed”.

1 Like