Kernel dies

The kernel dies in cell 11 and never restarts.
I tried to set the environment variable to a bigger size as recommended in the various threads but I get a permission error.

Please let me know how I can set the environment variable so I don’t get the timeout error

Thank you,

Neil

FYI

When I select the ml.m5.2xlarge
I get a permission error

Please let me how I can set this variable

Thanks

Neil A

Please use this address for the issue (fill the form):

The issue seems to be that I started lab 2 with the wrong environment variable set.

I can set the environment variable correctly when I start Sage maker but the program has the incorrect environment variable attached

Is it possible to load a clean version of lab?
Or some other sequence of steps to reset thd variable and attach it to lab2?

Every time you load the lab from scratch through aws, it resets to a clean version of the lab as far as I am aware of.

1 Like

I can’t get passed the kernel dying message and I don’t have permission to change the environment variable. I cannot proceed with the lab.

Please help resolve this issue

Hi Neil! Can you post a screenshot of the error messages you’re getting, especially the permission error when selecting ml.m5.2xlarge? Also, please show that you have indeed selected ml.m5.2xlarge as the instance type when you get that. We can send it to the dev team if there is a bug. I can’t reproduce this issue from my end so far. Maybe you can try selecting a different instance type (don’t press “Select” yet), then go back to ml.m5.2xlarge before pressing “Select”. That might get around the issue. Thanks!

Hi Gent! Sorry for jumping in here. I just saw a similar report recently, so I wanted to investigate if this is a bigger problem. Thanks!

Hi Chris!
I am also facing same issue, here is screenshot of access denied error

Hi Asadbek! From the error message, it seems like you’re selecting ml.m5.large. Please select ml.m5.2xlarge as shown in the screenshot in the notebook. Hope this helps.

Yes Chris

Here is the screen shot. I set the environment variable for the project correctly in the Launcher.

Then opened the Lab and selected the correct variable (ml.m5.2xlarge) and then got the following error:

Thank You,

Neil

It seems the lab may have the wrong variable attached and won’t let the user reassign the correct one.

One possible solution (I think) would be to start the lab again with the original file.
Then select the correct variable.

I usually save the original prior to making any changes but didn’t this time.

Hi Neil. From your 1st screenshot, you’re selecting ml.m5.large as the instance type. The error message in your second screenshot also indicates ml.m5.large. Please select ml.m5.2xlarge instead.

Chris - Yes thank you very much, that worked!!!

Neil

1 Like

Chris - Going to fast for my eyes to see.

Thanks again

Neil

1 Like

Great! Glad it worked!


Hi,

I have the same issue here. The kernel always dies in cell 11 and never restarts. I have tried another “instance type” that Chris suggested when selecting the kernel and it didn’t work either. Any help would be appreciated. Thanks.

Hi,

I had the same issue and Chris advised me to change the environment variable upon start up to ml.m5.2xlarge and that took care of the dying kernel in cell 11.

Neil A

Hi,

Thanks for the reply. Yeah, I had tried that instance type already and it didn’t work for me.

I opened a fresh issue since I am not even being given that option of the kernel in the dropdown to select and the default kernel keeps dying.

Hi Steve. Sorry to hear that. So far, I haven’t been able to reproduce the issue. Can you show that you have selected ml.m5.2xlarge in the selection screen before the kernel crashes? You can hover over the notebook environment button to produce a screenshot like below:

Please do not use any other instance type. Please retake a screenshot of the error (just like what you did in your post above) when you reattempt the lab with ml.m5.2xlarge. Also, if you get that error, please also send me your AWS account ID via direct message. It should be on the upper right of the AWS Console. You can refer to the second part of this article for instructions. I can forward it to our engineer. Thanks!

1 Like