Permission denied: WIA1/Building_a_Recurrent_Neural_Network Step_by_Step.ipynb

Permission denied: WIA1/Building_a_Recurrent_Neural_Network Step_by_Step.ipynb

I cannot save and submit this assignment, is there even anyone maintaining the course content?

1 Like

Hi @M115

There is a problem with the platform, and the staff team is working it. Will be in touch when the problem is resolved.

First, a notification on the website would have been great before people spend their hours finishing the notebook just to lose everything.

Also, please consider it is the end of the month and people might try to finish their courses before the new payment is due on the 1st.

1 Like

so… what’s going on?

We literally have no way to know that. It is in the hands of the course staff and Coursera. Apparently Coursera has not yet reported anything to the course staff.

FWIW you can protect yourself against the loss of work: just download the notebook by doing “File → Download as notebook (ipynb)” before you submit or save anything. That is also documented on the DLS FAQ Thread along with ways to download all the files associated with the assignments, not just the notebook.

well, in this case the question is of course adressed at the course staff and Coursera (who we are paying), and not at the mentors. i am sorry that you have to be on the receiving end of such messages, but we have no means to contact the responsible party directly i assume…

You can contact Coursera Help. It is documented on the DLS FAQ Thread. Of course it’s not clear how much of that type of contact actually results in reports back to engineering.

You also have exactly as much power to contact the course staff as we do. You can tag them on messages here. The problem is that they have other responsibilities besides answering questions here, so you can’t be guaranteed that they will see a message unless you tag them. I don’t want to get in trouble by advertising the names though and subject them to a flood of messages. You can figure it out by looking through the Users database of Discourse if you are so motivated. But trust me this has been reported.

thanks for explaining, but I don’t know what Discourse is and I am not motivated enough anyway to get familiar with yet another platform or whatever just in order to get what I paid for. I will just continue to finish my last assignments once they are back up and running, and in case I don’t make it I will request a refund. Let’s see how it plays out…
Thank you again anyway!

This is Discourse. The discussion platform we are using here. But your plan of just waiting for this to be fixed is the best idea. We will let you know if we hear anything.

I’m also have this problem in C5W2A2 Operations_on_word_vectors_v2a

Hi everyone! Sorry for the delay.

Kindly try this:

  1. From the blank notebook, click File -> Open.
  2. Tick the running notebook.
  3. Click Shutdown then Duplicate.
  4. Rename the old notebook (any filename).
  5. Rename the duplicate with the original filename (basically, just remove the -Copy1 string).
  6. Open this newly renamed notebook.
  7. You should be able to save this and also see the submit button after a minute.

You “might see an error about checkpoints failing. I think that’s okay because that’s related to the permissions of the hidden .ipynb_checkpoints folder. That is not needed for grading as far as I know. The changes should persist in the actual notebook itself even if they see that error. I submitted the notebook and got the expected grade.”

@Gregory_Axelrod @Daniel_Braun @M115


No sir, it doesn’t work. There is no permission, so no way to duplicate the notebook.

1 Like

Hi @M115,

Please try these steps. So far there are already 5 learners able to fix it with those steps. Let me know how it goes for your case.


I have tried every steps but it’s not work. How to fix it.

It doesn’t work.
In my opinion, you should assume that the problem appears to all users and not only to those who wrote a message in the forum.

Thank you for the instructions, they worked for me for the same problem with this assignment!

Hi @Gregory_Axelrod ,

The staff team is working with Coursera engineers to resolve this issue, as Coursera is our platform partner, responsible for the backend infrastructure. Please bear with us, we will post an update to the community as soon as a solution is found.

@Kotchaporn_KLOMJAI @Gregory_Axelrod

If the steps I have shared do not work for you, please share your information in this thread as required.


Hi @Mohamed_Waleed_moham, I have reposted your information to under this thread where all info are centralized.