Week 2 Residual Networks assignment cannot connect to Kernel

I am unable to get the Kernel to connect on the Residual Networks assignment. I have tried re-launching the assignment, resetting the kernel, and even disconnecting from my VPN. but in all cases the same thing happens. Nothing is listed for the kernel at the top, but as soon as I try to execute the first code block, the red ‘kernel disconnected’ box is displayed.

Do other assignments in Course 4 open and run normally? If yes, then you may have damaged your Residual Networks notebook somehow. One experiment to try would be to get a fresh copy of the notebook and see if that has a working kernel. There’s a topic about that on the FAQ Thread, but executing the procedure requires that you be able to do “File → Rename” to get your broken notebook out of the way. If you can get a clean copy, then worst case you can “copy/paste” your completed code over to the new copy. Of course there may be some error in your code that is causing the problem (e.g. an infinite loop that causes the memory footprint of the notebook to grow without bound).

If all notebooks exhibit this same problem, then it’s more likely some kind of IT problem. Some software (A/V or firewall) is blocking the connection.

It looks like none of the notebooks connect to the Kernel, including the previous weeks assignments that I worked on successfully a couple of weeks ago.

Are you using a different internet connection, or has your setup changed?

Exactly. If none of them work, then this has to be an IT problem of some sort. Most likely (as Tom says) something has changed either in the setup of your computer (configuration of your A/V software or your local firewall) or something on your local area net (firewall or proxy settings). If you are on a work network, you could check with your IT department if there is such.

One experiment to try would be to use a different computer or even a tablet on a completely different network. E.g. use a public WiFi network at a library or coffee house and see if that makes any difference.

Disconnecting from my work VPN did not help, however, switching to my personal computer caused the problem to go away. I will work there for now and have put in a ticket with my IT department to figure out what new security rule is blocking me on my work PC.