C2W3_Assignment grading error

I am stuck in getting my C2W3 lab assignment graded from course 2 “Machine Learning Data Lifecycle in production”.

The error is in grading. It results in all sections with 0/10 points and
a note: “There was a problem compiling the code from your notebook. Details: type_id”.

Even though the results are correct.

I tried checking the cell metadata, and refreshing the notebook and all other files but was still unable to get graded.

Your help is needed and much appreciated.

There is nothing wrong with the notebook. Please fix get_parent_artifacts.
Look at this line:

# Get the artifact id of the input artifact
artifact_id = store.get_artifact_types_by_id([artifact.id])

Only retrieve the artifact id and not the type for this line.
Don’t forget to run the notebook on coursera environment and submit ONLY after you see your output match the expected output as shown in the markdown cell that follows the test cell.

But why does it show the 0/10 for previous cells where the output in fact matches the expected?

If the notebook doesn’t compile, the entire assignment is scored as 0. Use #grade-up-to-here tag get get partial grade. See an example here

Thank you for your quick support!


I have completed all the assignment with correct answer . But im not sure why i’m i getting this error

Is the InteractiveContext you use created with the correct pipeline_root ?


[snippet removed by mentor]

Please click my name and message your notebook as an attachment.


Why create an instance of InteractiveContext needlessly in Exercise 2: ExampleGen that too without pipeline_root?

Thanks got the issue … It worked!