C3_W3_Assignment submit button not working

Hi All

I tried to upload C3_W3 Assignment (m2nist dataset) with my final result model.h5 many times, but the submit button just stayed grey’ed out. Can someone please help check?

thanks and best regards

Do you mean the button after which you upload the h5 file or the submit button in the notebook. If its the submit button on the notebook then you should refresh the workspace.

If its the other one then coursera takes care of that as far as I know.

hi there

After i’ve selected “create submission”, I clicked on the blue button to upload my h5 file from my own desktop directory, but it doesn’t seem to get loaded, hence the submit button stays “grey’ed out”.


Have tried refreshing, logged out and back in, still the same issue. And it only seems to be a problem for this particular assignment at the moment as I haven’t run into same problem on others.

hi Gent

My file size is around 28M, I see other people might have reported similar issues in the past. What would be the acceptable size for this assignment?


Managed to fixe the issue myself by changing the optimizer from Adam to RMSProp.

1 Like

The issue does seem to be indeed with the file size (once it’s below 20M), it was fine to upload/submit.

I see, good thing you fixed it and I will keep note if a similar problem arises here. Thank you.