C3W5 Graded Assignment - Can't check my progress

Hello, I’m having problems when trying to check my progress for Task 4 in week 5 graded assignment.

I have already follow the instruction step by step and successfully save the model artifacts to GCS bucket, but can’t pass this check.

The same issue happens also in the following check points. Can somebody help me, please?


Please provide the output of gsutil ls -l [saved_model_path] to show the contents of the directory.

1 Like

Hi Shanqui and welcome to the community! I was able to replicate the issue and will be reporting it to our partners. Seems like a new bug because the lab was working fine last week. Will update you asap. Thank you for reporting!

Facing similar issues

Facing issues while installations

Hi. From the screenshot, it looks like you selected the Dataflow Workbench. As mentioned in the instructions, please use the Vertex AI Workbench.

Hi everyone! Just an update: The Qwiklabs Support team has acknowledged the issue and is working on it. Thanks!

1 Like

Thank you Chris ! @chris.favila

Thanks Chris! Let me know once the issue is fixed!

1 Like

Hi @chris.favila, is there any update?

1 Like

Hi Shanqi. Our partners from Google have also filed a ticket to fix the checkpoint bug. Unfortunately, there is no update from them and Qwiklabs just yet. I can do a follow-up. By the way, did you already get a passing mark for the lab? We’ve modified the passing threshold so hopefully, this is not blocking you from getting the completion certificate.

Hi @chris.favila, yeah just got my assignment passed. Thanks for the help.

Good to know! If you did the lab and got predictions from the deployed model in the last step, you can safely assume that you’ve completed all the exercises correctly. The problem is just the grading checkpoints and hopefully, it will be fixed soon. Thanks!


I’m facing similar issues as well. Despite getting confirmation in the Jupyter notebook that the model is deployed – Qwiklabs does not seem to be recognizing it. Any help here would be much appreciated.

Hi Venkatesh and welcome to the community! As mentioned above, the Qwiklabs and Google teams have acknowledged the issue and we’re still waiting for an update. The checkpoints were working fine just a couple of weeks ago.

For now, as long as you get a prediction from the deployed models, you can safely assume that you’ve done the lab correctly. You were able to prepare, train and deploy models in the cloud using Tensorflow and Vertex AI.

You will also get a passing grade so it won’t block you from completing the course. Would also like to note that lab scores are not shown on the public certificate.

As far as I know, the problem is only with the grading checkpoints which our partners are still troubleshooting. I just made another follow-up now and hopefully, we’ll hear some good news soon. I’ll update this thread as soon as I hear from them.

Hope this helps and sorry for the inconvenience. We’re doing our best to coordinate the fix. Thank you!

1 Like

Hi everyone! The lab checkpoints have now been fixed! You can retry it if you want to get the perfect score. Thank you!

1 Like

Hi, I tried the lab this morning and I am still facing grading issues. Kindly help

Hi Oladotun! Welcome to the community! That error usually pops up when the Vertex AI notebook is not named tensorflow and is not created in the zone specified in the instructions (most likely us-central). Please check these settings when you retry the lab. If the error persists, please post a screenshot of the Vertex AI workbench screen here. It should show the name of the notebook. Thanks!

Thanks, that worked Chris!

1 Like

Hi, I’m going through the lab and I am having problems with creating the training and evaluation datasets:

I’ve followed the instructions up until now but for some reason I kept getting this error message. This is my workbench in case it might help:

Any help would be much appreciated. Thanks!