C4: ex-w3-a1 Grading Failure

Sorry in advance for the long post. I have spent numerous hours on this issue, including exchanging multiple emails with the Coursera support staff and they have referred me to this discussion board. Please help!!

Here is the current status of the situation:

  1. As background, I have successfully completed the Sequence Models course, as well as the first 2 weeks of the Convolutional Neural Networks (CNN) course, and I have never encountered this kind of issue with a Coursera programming assignment before.

  2. My code for Assignment 1 in Week 3 of the CNN course runs without error and passes all tests in the Python notebook environment.

  3. I have submitted it for grading a total of 12 times–each time the message “Grading failed” appears. I can provide screen shots of the grader output if needed. Usually they say, “Please try submitting again in 10 minutes. If the error isn’t resolved within 24 hours, please reach out to Coursera through our Help Center.”

  4. I have submitted in via 2 different browsers (Edge and Firefox) without ad blockers installed.

  5. I have tried 2 different networks (home and university) using 2 different devices (laptop and desktop).

  6. I have tried clearing the cache and cookies before submitting, as well as submitting via a private browser window.

  7. I have tried clearing all output and restarting the kernel in the Python notebook before submitting.

  8. Many of the times I have submitted this assignment, it takes an unusually long time (an hour or more) to complete the grading before returning with the “Grading failed” message.

  9. Coursera support staff are able to see the following error message on their end, but they are unable to do anything to fix it:
    {“errorCode”:null,“message”:“No item ItemId(CourseElementId(3VCFG)) in course”,“details”:null}

Please help!!

Tip: Do not ask the Coursera Help Center for technical support. They are helpless.

DLAI staff has contacts within Coursera’s technical team which are more effective.

So report issues here first, and ignore the Help Center.


Recently Coursera was having a technical issue that caused the graders for C4 W3 to not work correctly.

It was reported this morning that the issue was resolved. Other students (and myself) were then able to submit our work successfully.

How recently did you last try to submit your work?

You may also need to try this trick:

  • Use the Labs Help menu to “reboot the server”.
  • Log-out of Coursera.
  • Clear your browser cache.
  • Log-in to Cousera again. and try to submit your work.

You might also try this using an anonymous browser session.

If none of that works, please follow the below thread and post a reply there. The DLAI staff who is monitoring this issue will see your reply there.

Thank you, TMosh. My code passed the grading with 100/100 just now.