C4_W1_A2_Submission not working

I’m having an issue with the grader. I’ve completed the assignment and passed the tests on screen. When I submit assignment to the grader, it says it is marking it (there is the “submission being graded” message under the “My submissions” tab) but after a few minutes it goes back to the original screen of “your graded submissions will appear here” as if nothing was submitted. The line that shows the mark up top just says “You have not submitted. You must earn 70/100 points to pass”. I’ve tried restarting but that didn’t resolve it.
Any idea what could be wrong?


Yes, I think there must be a problem on the grading servers. I just tried submitting one assignment in DLS C1 and one in DLS C4 and both gave the same results you describe: it is “pending” for a few minutes and then just disappears and nothing gets recorded or updated.

I will report this to the course staff and Coursera and see if they can investigate.

1 Like

Thanks, hopefully I’ll be able to get it graded by the due date (midnight, 30 Oct).

Don’t worry about the due date. The deadlines here are just advisory: there is no penalty for missing them. You don’t have to take my word for this: it is documented under Course Info on the left menu on any of the course pages.

I have the same issue with other assignments, I think the server is down

I am having the same issue with Week 2 assignment.

1 Like

Same issue with week 3 assignment.

Same for me, do you think it might be working again today? I wanted to finish the course today because tomorrow starts a new month for me and I don’t want to pay for another month just because the servers are down today…

Same here, except it’s Week 4, Assignment 1.

(1) Waited for well more than 10 minutes. Note that, the page says “You have not submitted. You must earn 70/100 points to pass.”. When I clearly did submit it - that seems like an error.
(2) Tried using a different browser tab/window - no luck.
(3) Went through the instructions to referesh the workspace - restarted with a new version of the notebook, copied all my changes from my backup… It still runs into the same problem.

Hi all,

This is a problem we are seeing across multiple specializations. Coursera has been informed about it. Hopefully, it will be resolved soon.

Thank you for your patience,

1 Like

Just to let you know: It’s working again! :smile:


Thank you for letting us know!