C4W4 Graded Lab grading fails but don't understand why

In Week4 Graded lab Data Loss Prevention, “Check my progress” produce the following error and I cannot pass
Please grant owner permission to the service account qwiklab@qwiklabs-gcp-00-23e7fb5b16c6.iam.gserviceaccount.com

(1) I have excecated all the command without error.
(2) IAM dashboard suggest this account is set as owner

(3) All the following part( making requests to API) return expected output without issue.

I don’t see what can be wrong. Any suggestions?

1 Like

I am also facing the exact same issue.

Hi! Thank you for reporting. Will take a look at the Qwiklabs today and update this thread. Thanks again!

Hi Akie and Renjith! Unfortunately, I cannot replicate the issue. I am getting the correct behavior from the checkpoint:

Can you retry the lab? Preferably in a browser without any other Gmail accounts logged in. I ran it using Google Chrome. Also sometimes the checkpoint can be a bit delayed in reading the progress. It failed the first time I pressed it but it passed when I pressed it again after about 10 seconds. If the issue persists, kindly chat with a Qwiklabs agent to see if they have encountered it before.

Please let us know if their response is helpful or if you are still stuck. Hope it works this time!

Thank you, Chris, for checking. I did press check progress a couple of times, but things didn’t change. So that was not the issue.
I tried today with Chrome guest mode and able to pass the check point. What I did was exactly identical to the other day (it is just several copy and pasting), and I am not sure if it was browser google account (although I am 100% sure I logged on to google cloud with temporary student ID) or some unknown server side issues.

I see. That is strange indeed. Will keep an eye on this and report to Qwiklabs if it happens again to other learners. Hopefully it’s just a glitch. Glad it’s working now! Thanks for the update!