Have trouble opening Programming Assignment: Emojify

Hi guys, these days I’ve been having trouble visiting week2’s final programming assignment… As you can see in the image, I cannot open the lab using chrome… Any help would be appreciated.


Maybe erasing cookies or maybe there is a vpn involved. Hi @Mubsi maybe you can help with this.

1 Like

I was able to load it without trouble (C5 W2 A2).

Try “Kernel → Restart & clear output”
Then “File → Save and Checkpoint”.
The reload the page in your browser.

Thanks for the advice. :slight_smile: I already tried erasing cookies, still not working. And I’m not using any vpn.

1 Like

Thank you TMosh. When I hit “save and Checkpoint”, it became:

Seems something went wrong when loading the notebook…
After reloading the page, it just went back to the old problem.

1 Like

I think this is an issue with your browser, or your plugins, or your internet provider.

Or, you might have to try “Help → Get latest version”.

Hi @CharleneFung,

I have sent you a DM

1 Like

Tried it. :innocent: Doesn’t work…And I tried different browsers, login from different countries, and removed all plugins from browsers… still doesn’t work. Btw, I can open other programming exercises, except this one :rofl:

1 Like

I think there may be a problem with this notebook. I just took a look at the clean copy I got yesterday and it has a section like this in a lot of the “code” cells:

   "cell_type": "code",
   "execution_count": null,
   "metadata": {
    "executionInfo": {
     "elapsed": 2671,
     "status": "ok",
     "timestamp": 1611738624467,
     "user": {
      "displayName": "Mubsi K",
      "photoUrl": "https://lh3.googleusercontent.com/a-/AOh14Gip7OjOkdNkKxKDyWEQAq1o8ccGN_HrBTGdqjgQ=s64",
      "userId": "08094225471505108399"
     "user_tz": -300
    "id": "OvuoZ8pWcFIi"
   "outputs": [],
   "source": [ 
    "X_train, Y_train = read_csv('data/train_emoji.csv')\n", 
    "X_test, Y_test = read_csv('data/tesss.csv')"

It looks like maybe Mubsi did not do “Kernel → Restart and Clear Output” before saving the official version of this notebook. :nerd_face: But this does not cause me any problems, so maybe my analysis here is not relevant.

1 Like

The last time this notebook was updated and deployed to Coursera was Aug 2023. If the notebook was broken, by now we would have many reports about it.

That metadata seems to have been in the notebook for about 3 years.

Thanks for the detailed history. Yes, we’d know by now if this was really a problem in general. But maybe there’s a theory that Charlene has some other IT issue that interacts with the googleusercontent.com URL, e.g. a firewall on the local area net or A/V software.

It sounds like Charlene has already tried VPNs in addition to multiple browsers, but if the A/V software is on their local computer that might still get in the way. Maybe try a different computer or a notebook or the like.

1 Like

Good thought about those embedded URLs. They could be manually edited using the appropriate tool. The ipynb file is just text.

It is very likely that the notebook memory has increased (as seen happen before a few times already by other learners), causing it not to render by Jupyter. @CharleneFung, still hasn’t replied to my message so I can’t really investigate it.

Still waiting for the reply in the DMs.

1 Like

@TMosh, @paulinpaloalto, the notebook was actually “silently” updated 2 days ago. I have just “silently” published it again with “Kernel → Restart and Clear Output”, to be on the safe side. Though, I don’t remember running any cells. Only changing the markdown (but I could be mistaken, as cells might have accidentally run)

1 Like

So is a “silent update” not listed in the “View change log” tool?

That’s good to know (and very confusing).

Seems like it.

That makes the “View change log” tool useless.

Note that I just had the same issue as in the OP image, when loading the C5 W1 A3 assignment (Jazz Improv). The page loaded but there was no notebook content.

I tried again a few minutes later (after successfully loading the C5 W1 A2 assignment “Dino Island”), and then “Jazz Improv” loaded correctly.

Then i think that you need to update it to the latest version if your laptop is an old one