Machine Learning Data Lifecycle in Production - Week 1: Grading of assignment failed/ new submission not possible

Dear team,
there seems to be an issue with grading the assignment. “Assessment failed”. When launching the notebook again, there is no button to submit the assignment:

Pls. advise, thanx in advance

Hi Jorn!

Are you still facing this issue? Sometimes this is just a sporadic bug and the Submit button reappears when you open the notebook again after a few hours. If it is still missing, please try refreshing your notebook. Steps outlined in this post: C2W1 Assignment - grader output showed error - #4 by chris.favila .

Here are additional things you may need to watch out for to avoid that error:

  1. There should not be any cell in the notebook that throws an error. Otherwise, the grader will halt and not give a partial grade. This usually stems from submitting an assignment without completing all the exercises (e.g. doing Exercise 1 then pressing Submit immediately)
  2. You may have renamed the notebook and pressed the Submit button there. The grader expects the default filename when grading. That is the file opened when you launch the notebook from the Coursera classroom. For example, if the default filename is C2W1_Assignment.ipynb , then the grader will grade that notebook even if you pressed the Submit button from C2W1_Assignment_2021_05_11.ipynb

Hope this helps!


Hi Chris,

thank you for your hints.

Finally, the notebook was graded successfully.

Best regards


Awesome! Glad to help!

@chris.favila i’ve complete whole exercise and i’m getting correct result but still facing issues while submitting it says

There was a problem compiling the code from your notebook. Details:
name ‘dataset’ is not defined

Hi Marium! Welcome to the community! I assume you’ve already followed the hints above but still getting the error. If so, please check your inbox. We might need a copy of your notebook to replicate the issue. Thanks!

Hi Chris,
I am now having exactly the same error. It didn’t work after a few days. Shall I keep trying or if there is any way to fix the problem??? Thanks

Hi Jingchao! In Marium’s case, it was because of missing metadata in the notebook. Have you tried refreshing your workspace? Instructions here. Let me know if it works. Thank you!

Hi Chris,
Thanks for your quick reply. Yes, I have tried to refresh, reboot the notebook space. Still get zero score. Anything else to try ? thanks

Oh I see. Sorry to hear that. Can you send your notebook to me via DM? Will investigate. Thanks!

Is that caused by my task overdue? I notice there is a overdue sticker on top right of my space. Thanks. Not sure how DM works?

As long as your subscription is active, you can still submit your assignment. You can click on my name and click the Message button. From there, you can attach your notebook. Thanks!