Unable to Unlock Accomplishment for "Introduction to On-Device AI" short course after completing the short course

I have completed the “Introduction to On-Device AI” course, and my progress shows 100% completion. However, when I try to unlock my accomplishment, I receive the error message: “Something went wrong: user has not completed all course lessons.”

I have verified that all lessons are completed. I have also tried clearing my browser cache and logging out and back in, but the issue persists.

Could you please help me resolve this issue so I can unlock my accomplishment?

1 Like

did you run down the code lessons as well as the video completely???

Yes , I ran down all the code lessons as well as the videos completely.

@Mubsi Can you please have a look at the learner’s concern.

@Miratun Did you try logging out and log-in, and then check if the issue persists.

Also the green tick does tell you have viewed all the videos but don’t necessarily confirm if you run down all the lesson assignments. So kindly re-check if anything was not left.


hi @Deepti_Prasad, i have the same issue for a different course (carbon aware computing for genai developers)
cheers jan

@Deepti_Prasad , Yes, I tried logging out and logging back in, but the issue persists. Additionally, there were 3 attached Jupyter notebook assignments, and I ran through all the lessons in each assignment.

1 Like

I have the same issue with Carbon and LLMOps (both by Google) Other 4 short courses in my accomplished courses are working well for me to share their links via social media. As the two are blocked, I even more want to share about the two courses! But I am still good with the course contents even without the links. It’s free anyway!

@Deepti_Prasad Thank you, now the issue is resolved. Accomplishment is unlocked :smiling_face:.

Hi all,

I have been told this issue has been resolved. Please check and let me know.