W3_A1_Grading error

Why does this happen?

Are you sure you have the latest version of this notebook? Here’s another student about 2 weeks ago who had exactly the same symptom and in that case it was because of the case of 50 hidden notes in the “Optional” section of the assignment. Please have a look at that thread I linked (all the way through) and compare your list of hidden layer sizes in Section 6.

And here is another student who deleted (and changed code of) some cells from the Notebook and got the same error.

I didn’t change anything I wasn’t required to and the second submission was not an altered version of the first two. I just re-opened it and hit submit again, and the grade was given

I just realize that it is a Planar_data_classification_with_one_hidden_layer assignment. In the optional exercise, try removing the “, 20, 50” (maybe you don’t see 50) as shown in the below image, then save and then submit it. Let us know if it doesn’t work.

That also worked, but what is weird is that I submitted It immediately after realizing that error (a day after the assignment was due) without changing anything and it graded properly.

Hi @saifkhanengr, @paulinpaloalto, @Tobenna_Udeze,

Is this still an issue ?


Yes, a few more students facing this issue. Removing 20 and 50 solves the issue.

Hi @saifkhanengr,

If an issue has not already been open, can I ask you to do that ?


I guess Paul may have opened the issue (I am not sure). Let’s wait for his response.

Sorry, I thought I had created a Git Issue for this, but I can’t find it. I do remember seeing a commit to remove 50. Here’s the issue I just created.

Thanks for taking care of this and welcome back, Mubsi!

1 Like

Thanks, Paul! Will take a look.