Learning records of deep learning AI. disappeared

I have already finished 1 lesson of deep learning AI, and finished the test and jupytor program,but the records and the test results disappeared suddenly,so please help me,my teacher

best regards
kris zhang

Hi, Kris.

Sorry, but you may have been affected by the switchover to a brand new updated version of this course. That happened about 12 hours ago (8 April 3:00am UTC). When was it that you finished your work on the first assignment? I’m not sure there is anything we can do about this, though. They were supposed to warn everyone to make a backup of your work before the switchover, but it looks like that didn’t happen. Sorry!


Hi Kris,

Very sorry for that inconvenience. Can you clarify if you are a new learner or if you were already enrolled in the first version of the specialization and switched?

If you were already enrolled, here is a course announcement we made for C1, 2, and 4. Hopefully recovering your work wasn’t too time consuming.

"A​s of 7 April 2021, the Deep Learning Specialization has been updated to include newer and revised content.

I’m already enrolled in the original Deep Learning Specialization. What does this mean for me?

  • If you are currently enrolled in a course, you will continue to see the previous version of the content. This will allow you to complete the materials you already have access to and earn your certificate.
  • If you see the option to reset your deadlines, doing so will automatically enroll you in the new version of that course. Please note that you may lose some progress depending on your current progress and content changes in the new version. To minimize loss, download copies of your notebook before you reset deadlines.
  • If you would like to access the new version of the content urgently and do not have the option to reset your deadlines, you can contact Coursera via the Learner Help Center."

hello sir
I was not got any information about exchange the version of class, and yesterday I tried to do it again, (finished lab program ), but still can’t solve the result, so I want to confirm how can I do that I can study continuously

Hello sir
I finished the class and test program before April 8, from March 22 until April 7, I finished 3 weeks classes and test, but I was not get any information about the version update, and now how can I study continuously? Thank sir

Hi, Kris.
I’m curious how you found the link to this Discourse server. Was it from a forum post in your course? If so, that would prove that you are on the new version of the course, even though you did not ask to be. Sorry that we don’t have an immediate answer, but I hope we can get to one after a bit more research.

Hello sir
I confirmed again, I have enough time to study, and now I can submit the questions test result, but I can not submit the jupytor program exercise, could you please tell me how to do next?

Thank you so much

Hello sir
I will confirm again after class,thank you for your patient support

Hello sir

I checked again, and the records were empty, I can study again, but I try to submit the jupytor program, There is no submission button, I restart and clear output, still doesn’t work…so any other solution to solve it?

Thank you

Hi Kris, could you please tell me exactly which is the assignment that you cannot submit? I can try to test it on my side. It would also help if you could paste a screenshot of the top of the notebook like the one I’m including below:

In the past, when I had an issue the problem went away when I saved, closed the assignment and open it again but I guess you have already tried that.

Kind regards,

1 Like

Hi Kris, I’m not sure we are getting the same Jupyter notebook when opening the Lab. There is one thing you can try.

In the top right corner there is a Help button, click on it. Then you can get the latest update of the Notebook clicking on “Get latest version”

Before doing that I would suggest you to save the current Jupyter notebook locally if you have anything in it that you would like to keep / reuse.

Kind regards,

1 Like

hello sir

As pictures, it stil doesn’t work…and I change the web also image

Hi Kris,

Unfortunately, we are having more students with this issue since the last update of the course.

Could you please try the following steps?

  1. Select from the menu File->Save and Checkpoint, then
  2. Kernel->Restart and Clear Output and agree to the dialog box you get (“Restart and Clear All Outputs”)

Please let me know if this solve your issue.

Kind regards


Hello sir

It still doesn’t work

In C1, I am still unable to see my old content or the new content. The old content is because I finished this course many years ago and I just clicked the “reset your deadlines” link and the content of C1 was removed but the workspace was not updated with new content. In other words, my C1 is empty! There is no old content or new content. I verified that for the other courses, I still have the old content. I simply can do anything. Any idea how can I fix this issue?

I also cannot see submission button in my Jupiter notebook to submit my assignment.

@Bahador: Have you tried the “recovery” actions suggested by @albertovilla in his previous reply? Please let us know if that helps or not.

It would also be useful to know what browser and platform you are using (e.g. Firefox on Windows or …).

Yes I tried the recovery action and it did not work.
I am using Edge browser. I also used the Chrome, but the problem remained the same. the Submission button is missing!

Can you try this for a change? When the notebook finishes loading up and the submission button is not there, click on the restart kernel button (rather than using the option from the menu). In the past this method worked for me and is still working for me. image