Notebook Doesn't load to browser (Says: Failed to fetch Data)

Hi, I purchased the deep learning Specialization yesterday. When I tried to do the first assignment today, I was surprised that the link fails to open the notebook (It goes to the URL, but says: Failed to fetch Data). Is it a temporary issue? if not, then please help me to get a solution to this. I’m using Chrome Version 103.0.5060.134 (Official 64-bit build) on Linux Presently.
Shall appreciate it if anybody can help me with this.

Hi @Sudipto_Banerjee ,

I have no problem in loading the assignment “Logistic Regression with neural mindset” using both Chrome and Edge.
So, the system is running normally. Could you have a look at your browser setting to see if that might the cause of the problem.

Hi @Sudipto_Banerjee,

If the assignment it not at all opening, then that might be an issue with Coursera. You can contact them via the chat. They are the best people to help you out with this.


Hi @Kic , thank you for taking the time to reply. Might be something about the browser version, but I couldn’t make it work on the said chrome browser version (and other browsers) running on Ubuntu 20.04…
No special settings are there.
Strangely It works on non-Linux systems though…
I’ll be using such a system for submitting the assignments.
Thank you for your kind help.
Best Regards,

Hi @Mubsi , Appreciate the revert. The notebooks are not loading from Chrome on Linux; but I’ve access to another non Linux system and they works there… I’ll be using the same for submitting the assignments.
Thank you again for your kind help.
Best Regards,

1 Like

I have Ubuntu environment, and tested with Chrome.

The version of Chrome is 103.0.5060.134 (Official Build) (64-bit). So, I believe it’s the same environment.

There was no problem in executing all cells, and, also submission.
Firefox also works fine on Ubuntu.

Hi @anon57530071 ,
Thank you for the revert;

This is pretty consistent in my system…

System details: 5.15.0-41-generic #44~20.04.1-Ubuntu SMP Fri Jun 24 13:27:29 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

If it works in your system but not in mine, I’ll check at my end and post If I find anything. By the way, It’s not stopping my work, so it might as well be considered low priority if it’s an isolated issue…
Thank you for your kind help.

Best Regards,

The same problem appears in course2 (Course1 somehow the rest of the assignments were loaded, and I was able to complete that course.)

Course2 again it’s the same with the 1st assignment:

I have tried through multiple browsers, no other features in Coursera are showing problems, and no network speed issues are there, only the new assignment notebooks doesn’t load.

Shall appreciate if someone can help me to get a permanent solution on this, as my subscription is for limited time; and if I cannot finish the assignments in time, it’ll cost me both time and money.

Best Regards,
Sudipto Banerjee

Hi, Sudipto Banerjee.

We understand your pain. Please check this link. Hope, the issues get resolved.

Hi @Sudipto_Banerjee ,

The mentors here have not control of the system, please contact Coursera learner help centre to resolve this issue. They have a chat line which is the quickest way to contact them.

Hi @Rashmi and @Kic,

Appreciate your kind support and response.

I have approached Coursera support through form and email (somehow the chat wasn’t working for me), and Coursera Support diagnosed it as a CORS issue. Coursera Support suggests installing a plug-in to disable the CORS policy (browser’s default security against CSRF attacks as the article says) otherwise I may observe unpredictable loading behavior with the Labs from time to time.

Attaching a screenshot from my system where the error can be observed, and the feedback with a medium article link shared by Coursera support, for anyone having a similar issue in the future.

Coursera feedback:

" We can see there is a Cors Policy error message, this is something related to your internet connection restrictions or device restrictions. If you would like to unblock this, simply activate the add-on and perform the request. CORS or Cross-Origin Resource Sharing is blocked in modern browsers by default (in JavaScript APIs). Installing this add-on will allow you to unblock this feature.

You may also get more information on how to resolve this issue on the external website here.

It is great to know that the labs are working now, however, if you do not unblock this, the issue may persist."

The above is FYIP.

Best Regards,

Hi, Sudipto Banerjee.

Great, that it worked for you and much thanks for letting us know what the problem actually was and how others can resolve the same issue in future :slight_smile:

[Edit contents based on the request from Deeplearning.AI]

This is the error in server side setting to allow cross-site resource sharing. Coursera IT team needs to set CORS properly.

But, if you change a setting in your browser side, then, your browser can be a target for XSS (cross site scripting). A simple example is, if someone cracks into a Coursera site and puts Javascript to access to their anomaly site, your browser easily goes to that site. Then, your credentials may be stolen.

So, it is better for you to minimize the time to disable CORS check. And, do not access to any other site. As soon as you finished an assignment, then, you are better to enable CORS check for your safety. This is not a complete workaround but, is better.

In any cases, please access with a browser default setting. Changing CORS setting is the last thing to do. And, do not forget to put back.

Hi @anon57530071 ,

Thank you so much for the detailed explanation.
@Mubsi , may be this should be brought to the Coursera IT team’s attention.

Hi @Sudipto_Banerjee ,

If you have lost time due to this loading problem, may I suggest you speak to the Coursera support team and ask if they could make up the lost time for you if you are not able to finish the assignment before your subscription expired. The problem is really on Coursera’s system.

@Sudipto_Banerjee , @Rashmi

May I ask one thing ?
What is your browser language setting ?

I think I could finally reproduce the problem.

Here is the result.

You see some interesting browser windows. One is success, and the other is not.
The trick is;
One is accessing “”, and the other is accessing “”.
Of course, the error showed up with “”.

Usually, when we create a system for W/W, we create some regions to split the world from a capacity and load balancing view points. I do not know how a request is dispatched in the Coursera infrastructure, but, once your request is dispatched to the India server, then, error occurs. I suppose there is an error in CORS setting in some of Indian servers.

And, the reason why I asked your browser setting is, a language selection may be one of candidate for a request routing. If you are not using “en” as a default language, please try to set it.

Even in the current situation, the easiest workaround is to change URL. :slight_smile:
Fortunately, these system has a same path to access the resources except the server address.
In your case, it starts with “…”. Just click URL, and change “in” to “www”. Then, you will most likely get the right contents.

I do not have 100 confidence, but think worth to try.

1 Like

Something very interesting to receive after going through your reply Nobu Asai. Thanks for bringing in this angle.

HI @anon57530071

That is very helpful to know the possible cause of the problem. Thank you so much.

Hi @Kic,

Thank you for letting me know. I shall inform them.