Troubleshooting: Problem with Lab Access and Start Time

When I try to request the large instance, I get this error:

If I try to run the notebook on the medium sized instance, it crashes.

1 Like

Hi Buddhika. From the screenshot, it seems you clicked on Sagemaker Canvas instead of Sagemaker Studio. Kindly watch the walkthroughs in class to know which to click. Thanks.

1 Like

Hi Krystian. From the screenshot, looks like you clicked on ml.m5.large. You will indeed get that error. The lab instructions specify this instance instead: ml.m5.2xlarge. Hope this helps.

1 Like

For some reason it ends up in the same maker canvas! Have a look at the screenshots.

1 Like

Hi. That’s strange. Please try logging on Coursera from a private session in Safari or a different browser (e.g. Chrome), then launch the lab from there. Hope that will work.

1 Like

I am still getting this issue when accessing SageMaker:

1 Like

Hi Marius. It seems like you haven’t clicked Studio on the left side menu yet as shown on the walkthrough videos. That looks like the screen when first landing on Sagemaker.

1 Like

Hi Chris, I am facing the same issue mentioned here, during Lab1 of the course when launching Sagemaker, it defaults to Canvas and I see a blank screen (as one of the previous learner posted in this thread), I can see other services and console fine. I also tried Incognito mode, did not help solve the issue. Please advise. Thanks

Hi NT. That’s strange. Can you do these?

  1. Make sure you are logged out of personal AWS accounts (if you have one).
  2. Log in to your AWS Student account by launching the lab from the classroom.
  3. Search for Sagemaker and click.
  4. If you get redirected to Sagemaker Canvas automatically, please go to the address bar of your browser and replace the later parts to: sagemaker/home . For example, if you have something like:, change it to:
  5. Check that you are still using an AWS student account. The account at the upper right should read something like voclabs/user....

Hope this helps!

My lab is not starting error “Your lab is starting…Please wait”, I tried one day after it is same error.

1 Like

Hi Abhay and welcome to the Forum! If you mean the AWS button stays yellow for a while, that is to be expected. That message is not an error. It can take up to 30 minutes before it turns green as mentioned in item 4 of the FAQ.

However, if at any point it goes back to red (from yellow), please press Start Lab again and see if there are any error messages thrown. You can fill out the form in item 8 of the FAQ if it matches any of them. You can report the behavior here if it’s something else.

But hopefully, it will work on your next attempt after waiting for a bit. Thanks.

In week k3, when running the cell that adjusts the model based on the feedback from the toxicity model, the cell was running for much longer than 20-30 minutes (maybe an hour or more?). I refreshed the screen to see if something updated, and the window closed completely. When I tried to get back into sagemaker, I got an AccessDeniedException. How can I complete this lab? Also, I made certain to choose the correct kernal, double checked, and ran the code at the beginning of the lab to confirm.

Hi Stephen. Sorry this somehow slipped from my notifications. If you’re still having issues, please send me a screenshot of the exact error message you’re getting. Thanks!

start lab is not working for me and im trying since morning, its just loading. What can be done?

I’m sorry. I got to the end of the lab but went to do something else and my auth token expired after 2 hrs. Now I can’t launch the AWS lab.


   Failed to load resource: net::ERR_BLOCKED_BY_CLIENT

2main.php?m=clabide&mode=s&asnid=1843535&stepid=1843536&hideNavBar=1:11030 AWS Lab status: terminated.

main.php?m=clabide&mode=s&asnid=1843535&stepid=1843536&hideNavBar=1:470 Uncaught ReferenceError: closeMaintenanceBanner is not defined
at HTMLElement.onclick (main.php?m=clabide&mode=s&asnid=1843535&stepid=1843536&hideNavBar=1:470:122)
main.php?m=clabide&mode=s&asnid=1843535&stepid=1843536&hideNavBar=1:14474 DEV: Error - Escape Hatch Not Added to Terminal Uncaught (in promise) Error: Could not establish connection. Receiving end does not exist.
main.php?m=clabide&mode=s&asnid=1843535&stepid=1843536&hideNavBar=1:13684 Starting AWS Console
main.php?m=clabide&mode=s&asnid=1843535&stepid=1843536&hideNavBar=1:11137 startaws: error
main.php?m=clabide&mode=s&asnid=1843535&stepid=1843536&hideNavBar=1:11160 failed on start due to status…
main.php?m=clabide&mode=s&asnid=1843535&stepid=1843536&hideNavBar=1:11030 AWS Lab status: terminated.

I’ll go do week 3 in the meantime.

Hi , My lab is not starting, the button is still red. The message showing up is “Your lab is starting…Please wait”.
Edit: got started after 30 mins

1 Like

Hi Vincent. Please let me know what error message you get when you click the Start Lab button in Vocareum. You can take a screenshot for clarity. Thanks.

Hi Chris, It was fixed after maintenance. Thanks

1 Like